I'm trying to have a Windows program (Janome Customizer) run with wine. I have an "out of the box" Ubuntu 64bits 12.04 install, and just ran Software Center to update all packages.

Installation of Customizer went OK, then I run the program, a window appear, but nothing happens when I click a button. So I run the program with what I found in the shortcut installed by wine:

john@mylaptop:~$ env WINEPREFIX="/home/john/.wine" wine "C:\\windows\\command\\start.exe" /Unix "/home/john/.wine/dosdevices/c:/users/Public/Desktop/JANOME Customizer.lnk"

I get two warnings:

fixme:exec:SHELL_execute flags ignored: 0x00000100
fixme:exec:SHELL_execute flags ignored: 0x00004100

The Customizer window appear, and when I click a button this error is printed:

err:module:import_dll Library MFC42.DLL (which is needed by L"C:\\\\Program Files (x86)\\\\janome\\\\Customizer 10000 Plus\\\\MC9500\\\\MkStitch.dll") not found
err:module:import_dll Library MkStitch.dll (which is needed by L"C:\\\\Program Files (x86)\\\\janome\\\\Customizer 10000 Plus\\\\MC9500\\\\EasyImport95.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\\\Program Files (x86)\\\\janome\\\\Customizer 10000 Plus\\\\MC9500\\\\EasyImport95.exe" failed, status c0000135

So I googled for this error and tried to install mfc42 with winetricks, but I get the error:

john@mylaptop:~$ winetricks mfc42
Executing w_do_call mfc42
Executing load_mfc42
Executing mkdir -p /home/john/.cache/winetricks/vcrun6
to /home/john/.cache/winetricks/vcrun6
--2012-07-28 08:58:50-- 
Resolving download.microsoft.com (download.microsoft.com)...,
Connecting to download.microsoft.com
(download.microsoft.com)||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-07-28 08:58:51 ERROR 404: Not Found.


I tried to manually install mfc42 with other google results, to no avail. I would prefer to use winetricks. If I can't do it with winetricks, manual install belongs to another question.

Just to be sure, I tried booting on a live CD (USB key, actually), with Ubuntu 12.04 32bits. Installed wine through Software Center, but then running winetricks mfc42 yields the same error.

Interestingly, on another computer which I use daily, plugged into the same internet router, installing mfc42 works:

11:35:45 ~>winetricks mfc42
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
Executing /usr/bin/cabextract -q /home/jrouquie/.cache/winetricks/vcredist.exe -d /home/jrouquie/.wine/dosdevices/c:/windows/system32 -F mfc42u.dll
Using native,builtin override for following DLLs: msvcrt
Executing early_wine regedit c:\winetrickstmp\override-dll.reg
Install of mfc42 done
winetricks done.

11:36:29 ~>winetricks mfc42
prerequisite vcrun6 already installed, skipping
Install of mfc42 done
winetricks done.

11:46:00 ~>

Thanks for any help installing mfc42.

6 Answers 6


Adding the Wine PPA from: http://www.winehq.org/download/ubuntu solved the problem for me.

sudo add-apt-repository  ppa:ubuntu-wine/ppa
sudo apt-get update && sudo apt-get upgrade
winetricks  mfc42
  • 10
    NOTE: winetricks mfc42 should be winetricks dlls mfc42 in newer version.My Version is 20150206.winetricks dlls list show a full list. :-)
    – wener
    Mar 2, 2015 at 1:31
  • winetricks dlls list | grep mfc42 will do the trick
    – Sencer H.
    Apr 28, 2016 at 8:29

For some reasons winetricks mfc42 is not working.

Found an alternative way to download mfc42.dll from here. Hope the link is safe enough.


I copied the files from the other laptop:

scp* .cache/winetricks/vcrun6

and it worked.

I'm sorry this is not a solution for someone else browsing here, but at least my problem is solved.


I tried a bunch of stuff but don't know what actually solved it for Ubunutu 12.04. I copied the dll from a windows machine and pasted it into ~/.cache/winetricks/irfanview

which I think winetricks had created for me.

Also - the winetrick scripts I think was looking for the wrong version of Irfanview (meaning not the one I had) so I changed the name of mine to match what was being sought.

After that, I manually ran the setup program for irfanview in wine and this created a desktop Icon and now all is working!


My answer from another post. This works for all missing DLL files: https://askubuntu.com/a/581881/335595

Problem: MFC42.DLL is missing

Simple fix and this works for any missing .dll files on PlayOnLinux or even Windows itself.

  1. Close your PlayOnLinux & Wine programs. Kill all instances. ("ps aux" and "kill -9" commands)
  2. Google for the dll file name (MFC42.DLL). You'll find a bunch of sites where you can download the file.
  3. Drop the file into your Windows virtual drive's System32 folder - System32 is the core Windows system libraries folder which is scanned and all DLLs there are loaded into Windows:

/home/user/PlayOnLinux's virtual drives/virtual drive name/drive_c/windows/system32

  1. Start your wine/PlayOnLinux and try opening the software again. It should load now.
  2. You may have other DLLs etc missing, so repeat the above steps until you have all the necessary DLLs loaded.

Source: Many years of tears of rage, pain and suffering with Windows.



Running wine on Ubuntu 14.10. Found that wine explorer would run, but some "3rd party" programs would not, in my case it was femm42, a finite element analysis program for magnetics. In this case, the missing dll was mfc90.dll, but this doesn't really matter. Just try to locate your particular missing dll on the internet and download it. Next, examine any particular dll within the wine/windows application to uncover its location. I found that the dll's showed up at four locations, not just under system32. After copying the missing file to all such locations and updating the Ubuntu database, femm42 worked. NOTE: I'm running 64 bit, which required the four locations. It appears that 32 bit systems may only require copying to two of these locations.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .