5

I've been using the weather indicator for a while now on 12.04 and for the past day or so it hasn't been able to update. It just shows the same weather icon (the sun) and the same temperature all day. Right now it's 2AM and it thinks it's sunny outside at 72 degrees when it's actually about 62 degrees outside right now. From the drop down menu it just keeps saying 'refreshing, please wait' I've tried uninstalling and reinstalling it through the software center, logging off/restarting and nothing seems to work. Any thoughts for this issue? Thanks in advance.

| improve this question | | | | |
4

I guess the problem is in unreachable www.earthtools.org - or rather unexpected answer from there. I usually get very slow (10+ seconds) 404 from there.

In indicator logs (~/.cache/indicator-weather.log) you can see a lot of entries like: ERROR - Weather: error reaching url 'http://www.earthtools.org/timezone-1.1/[your position]

| improve this answer | | | | |
3

Remove indicator-weather and install better and more functional and updated my-weatherindicator with geolocation support.

ppa at https://launchpad.net/~atareao/+archive/indicators

| improve this answer | | | | |
  • 1
    I think that's good advice. I used to prefer the indicator-weather but lately my-weather-indicator has definitely moved ahead, especially since indicator-weather never seems to have fixed the clock to use daylight-savings-time. And Atareao seems to have been putting lots of effort into improving my-weather-indicator; it's become very reliable and stable. (I run it on 12.04 and on 12.10.) – Kelley Jul 31 '12 at 3:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.