Possible Duplicate:
Slow wireless with an Intel 4965

We run Ubuntu 12.04, 32bit, with the current kernel 3.2.27-generic on an MSI EX700.

I've already added the 11n_disable=1 tweek, without whcih, wireless has been unusable.

Now, it works OK, but speedtest shows:

Windows XP - down 11.68mbps, up 2.07mbps

Ubuntu 12.04 - down 2.06mbps up 2.0mbps

We've disabled ipv6, tried static and dinamic IPs, tried both swcrypto=0 and swcrypto=1 options, none of whcih made any difference.

The problem may be the symptom of high packet loss. For example, here's the output of iwconfig after booting and testing the speeds:

wlan0     IEEE 802.11abg  ESSID:"amu"  
      Mode:Managed  Frequency:2.462 GHz  Access Point: 00:78:9E:FA:32:C8   
      Bit Rate=54 Mb/s   Tx-Power=15 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off
      Link Quality=58/70  Signal level=-52 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:11  Invalid misc:3627   Missed beacon:0

I've posted a help request before with lots of technical info and outputs.

  • Is the card a 4965AGN? And disabling N will certainly drop your speed that low... – ish Jul 28 '12 at 8:25
  • The card is AGN, yes, but why do you think the speed should drop? – mikewhatever Jul 28 '12 at 11:10
  • Because 11n_disable disables 802.11N, restricting you to 802.11G speeds (54 Mbps) only... – ish Jul 28 '12 at 11:24
  • 54Mbps would have been fine, but all I get on Ubuntu is 2Mbps, and that's the problem I've been trying to solve. – mikewhatever Jul 28 '12 at 11:39
  • 1
    @SimonB, suppose the neighbor's AP works better, what then? The laptop functions as a home computer, and I have to use the AP provided by the router in the house. – mikewhatever Aug 5 '12 at 2:57

(answer in progress)

The iwl4965/iwlegacy driver has had a number of regressions in the past, but they've usually been fixed.

The high invalid misc number may be related to your low throughput.

Please try/test/answer a couple of things, and ask me for a howto when needed:

  1. Do you experience this problem with the Ubuntu 12.04 Desktop Live CD (which runs kernel 3.2.0-23, IIRC)?
  2. Can you try using wicd instead of NetworkManager?
  3. Can you compile and try the latest iwl4965 driver from the compat-wireless tree?
  4. What is the manufacturer/model number of your router?
  5. Does your laptop have bluetooth?
| improve this answer | |
  • First, thank you for your interest in the question. Not sure what regressons were fixed, from admittedly little that I know, that particular card had problems with 802.11n standard for years, and it still doesn't work. ...and don't get mestarted on Intel graphics drivers. Anyway, back to the topic: 1-I don't know. 2-Yes. 3-Not sure. 4-The router is sagemcom F@st 3184 with custom firmware. 5-Yes. – mikewhatever Aug 11 '12 at 5:40
  • 1. Can you try booting from LiveCD once - that way we know if this is a recent regression, or something older. If you ever had older Ubuntu 11.10, etc. on this laptop, did the wireless work OK then? 2. OK, thanks. 3. Can you try that? Follow the instructions in this answer,, just replace alx with intel when calling the driver-select script. This process can be automated to find you a driver revision that just works.... 4. Thanks. 5. Can you try with all bluetooth devices off, or better yet, with iwlegacy's bt_coex_mode (IIRC) set to ON? – ish Aug 11 '12 at 7:21
  • 1.I've not been able to test the CD yet, the laptop owner is about to move flat, will do it asap. 3. The driver from CW is broken as well, same as the default one. 5. Apparently, the bluetooth adapter is undetected, which is yet another unresolved problem. – mikewhatever Aug 13 '12 at 23:16
  • Tested the Precise ISO with 3.2-23-generic-pae. Same problem. – mikewhatever Aug 26 '12 at 20:13

rfkill is a small tool to query the state of the rfkill switches, buttons and subsystem interfaces.

Maybe try:

rfkill unblock all

I assume based on your question that you tried different modules versions and configurations if not please do it :)

I hate to say that, blacklist iwl4965 module and try using ndiswrapper.

| improve this answer | |
  • The device is not blocked. It actually works, but is slow. – mikewhatever Aug 11 '12 at 5:41
  • @mikewhatever Have you tried ndiswrapper? – pl1nk Aug 12 '12 at 22:04
  • Nope. We don't want to keep Ubuntu on that machine at all costs. Had crappy Intel wireless been the only problem, playing with ndiswrapper would have been justified, but that's not the case. One needs to know when to give up, but thanks for the idea. – mikewhatever Aug 13 '12 at 23:24

There seems to be no fix. Replace it with the same form factor if you can find it.

Intel Pro 4965AGN is old (about 2007 or so), and apparently, it had this problem on Linux for many years. It is unlikely that Intel will ever fix the driver for such an old piece of hardware, that it hasn't been able to fix thus far. I'd imagine this task is of a very low priority on the maintainers' to do list,if it's on the list at all. It is unfortunate, because Intel branded wireless cards used to have good Linux support, and were known to work out of the box.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.