I've experienced this problem every time (3 times now) I install Precise and run a dist-upgrade: when booting up, I get thrown a gfxmode error, followed by either a long blank screen with a single blinking cursor (with splash on), before showing the plymouth splash for all of a split second.

I use the workaround for the gfxmode error, but I still end up with a weird-looking boot up because of the splash not showing until the very end. My main concern though is why this sort of thing occurs in the first place, and what might be happening during the update process to be causing this. (And I'm pretty sure it's something that was caused by updating; the boot process was fine until I did an upgrade).

  • not sure what the question is here so let me rephrase it; You had a gfxmode error which you resloved but after you resolved the gfxmode error, you only get the blank purple screen for a second and are wondering why you don't have the Ubuntu screen with the flashing dots? – TrailRider Jul 28 '12 at 4:43
  • @TrailRider, pretty much. More specifically, I'm wondering why both the error and the plymouth splash problem happened in the first place, and am postulating that an update caused this regression. – tjmeneses Jul 28 '12 at 4:55
  • as far as the gfxmode error, it could be related to an upgrade, I'm not sure. but the boot screen is another matter altogether, I posted an answer about the that issue, can't help with the gfxmode error – TrailRider Jul 28 '12 at 5:18
  • THIS answer explains why the gfxmode error is happening but still not what caused set to not be added to the line like it should have been in the first place.. – TrailRider Jul 28 '12 at 5:24

I'm not sure about why the gfxmode is happening(a quick search on askubuntu only game me ways to fix it not a root cause) but is is unrelated to the missing boot screen.

The "missing" boot screen is normal behavior in 12.04 in my experience, but the link that I provide dates back to Jan 2011.(may have more to do with how fast your processor is, I only noticed this with my new computer, an Intel Sandy Bridge, which I bought to install 12.04 on, my old computer was 6yrs old and alot slower)

paste from The Linux Experience


Plymouth is a very young piece of technology and it is still not as solid as one would desire. One of the most frequent problems is the one I described above, where you get a black screen with a blinking cursor instead of your shiny Plymouth splash screen.

Essentially, the root cause of this problem relates to graphics drivers loading slowly, too slowly for the system to wait for them. The file system is checked and loaded in a shorter time, thus allowing X to load, perhaps making it unreasonable to have to wait for those graphics drivers to load.

If you want to read more about it the link has a goodly bit of information about it. If you just want to get your screen back I will copy the directions form the site(I used these commands myself, I hated looking at the blank screen)

  1. Open a virtual terminal and type the following command:

    sudo gedit /etc/initramfs-tools/conf.d/splash

    This file may not exist, so you may be creating it from scratch now.

  2. Enter the following content on the file you opened on the previous step:


  3. Close and save the file.

  4. Now, run the following command to commit the change:

    sudo update-initramfs -u

After rebooting you will have the splash screen back,also you will be able to see any text when pressing Esc during the splash screen or remove quiet splash from the boot commands, without this fix even if you remove quiet splash, you will only see a blank screen until the log in screen(lightdm)

|improve this answer|||||
  • Thanks for looking into it, @TrailRider. I'm guessing that any attempts to dig deeper into the problem will deserve a full-blown bug report (which I'm guessing has already been filed countless times), so I'm satisfied knowing this much. Hopefully, putting the info of the components of the problem into a single answer will help a lot more people. On a sidenote, do you think it would be worth it to set up a different splash manager than plymouth? – tjmeneses Jul 28 '12 at 16:14
  • @tjmeneses "do you think it would be worth it to set up a different splash manager than plymouth?".......if you are wanting to customize the splash screen, there are already programs out there to do that, some are mentioned on askubuntu, I believe. I don't use them so I don't know much about them, have only seen them in passing. If you are askig b/c of the issue with it not showing, this fix will work just fine, I have had no problems using it. From reading the blog I linked to, it seems it's more an issue of Ubuntu booting too fast, not a problem with plymouth per se. – TrailRider Jul 28 '12 at 17:19
  • @tjmeneses I guess the short answer in my last comment is, unless you are looking for special customizations, plymouth is quite sufficient after yo apply the fix. Plymouth is can even be disabled and Ubuntu will still boot but with a blank screen until login. It is more of an eye-candy than anything important. – TrailRider Jul 28 '12 at 17:20
  • To be honest, neither fix (gfxmode nor plymouth) worked for me. The file that is mentioned where you have to add 'set' already has it, so to fix it, I needed to look for any other file in /etc/grub.d with gfxmode, and found it under the proxified scripts folder. With the initramfs fix, it changed nothing obvious to my boot process; in fact, I think it might have caused something to break, as applying it started causing an application crash every startup. Now I'm at the point where I just wanna reset everything if possible. – tjmeneses Jul 29 '12 at 0:53
  • @tjmeneses It sounds like a graphic card problem, I would not think that the initramfs would be likely to cause crashes, that command only reconfigures the boot file to include the framebuffer=y file to force the system to wait for plymouth. I have not heard of this happening at least. I would more suspect that editing the grub.d file is likely what is causing your crash, however, I am out of my element there so I could be wrong. I'm just at a loss as to how adding the file for plymouth would cause a crash afterstartup, plymouth is no longer in use by the time you see the login screen – TrailRider Jul 29 '12 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.