Possible Duplicate:
How to stop Thunar being default file browser

I have found this question: How to stop Thunar being default file browser

I have installed Xfce because I don't like Gnome that much. I am not finding Thunar any good as it doesn't support SMB browsing and we have a selction of samba NAS shares in the office (so I really need it).

I want to make Nautilus my default file browser like it is under Gnome, but after running the script linked in the answer of that previous question (once to set Thunar as the default [which was already the case] then again to change to Nautilus), Thunar is still the default and still after a reboot.

What else do I need to change?

The other answer suggesting to run the following commands also hasn't made a difference;

gconftool-2 --set --type=string /desktop/gnome/url-handlers/file/command 'nautilus "%s"'
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/file/enabled true
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/file/need-terminal false

I'm rather stumped. I have also tried to ensure "nautilus" is configred by hand, in the correct files, have I missed any?

user@machine:~$ cd /usr/share/applications
user@machine:/usr/share/applications$ grep -r nautil *.desktop
brasero-nautilus.desktop:Exec=nautilus --no-default-window --no-desktop burn:/// 
nautilus-autorun-software.desktop:Exec=nautilus-autorun-software %u
nautilus-browser.desktop:Exec=nautilus --no-desktop --browser %U
nautilus-computer.desktop:Exec=nautilus --no-desktop computer:///
nautilus-folder-handler.desktop:Exec=nautilus --no-desktop %U
nautilus-home.desktop:Exec=nautilus --no-desktop
network-scheme.desktop:Exec=nautilus --no-desktop network:
xfce4-file-manager.desktop:Exec=nautilus --no-desktop %U

If anyone can point out what's going on here I would be very grateful. I can minimise this window, double click a desktop folder, and Thunar pops up, its constantly taunting me!

user@machine:~$ uname -a Linux bensley-n2 2.6.32-41-generic #94-Ubuntu SMP Fri Jul 6 16:51:39 UTC 2012 i686 GNU/Linux 
user@machine:~$ lsb_release -a
No LSB modules are available. 
Distributor ID: Ubuntu
Description:    Ubuntu 10.04.4 LTS 
Release:    10.04 
Codename:   lucid

marked as duplicate by Anwar, Thomas Ward, Jorge Castro, Eliah Kagan, jokerdino Aug 9 '12 at 3:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • On many a forum I have seen people using the default applications chooser (Under the "Utilities" tab) to change their default file manager, but this simply isn't and option for me. Screenshot: i45.tinypic.com/2m2ier7.png – jwbensley Jul 27 '12 at 20:48
  • Read the entire question before posting Anwar, I have already referenced that question and how the answer there has not worked for me. Cheers. – jwbensley Aug 8 '12 at 15:14
  • Anwar, in regards to you comment on exo-preferred-applications, read mine directly before that, clearly that is not working for me. Cheers. – jwbensley Aug 8 '12 at 15:15
  • did you try this answer? – Anwar Aug 8 '12 at 15:15
  • Those are the same answer! One via the GUI and one via the terminal, which again, I have already said, doesn't work for me as that option is not available for me in that application. Please read before posting. – jwbensley Aug 9 '12 at 17:04

I installed Ubuntu 12.04 with Xfce(xfce4, not xubuntu-desktop) today and i have Nautilus as my default file manager. I Just pressed Applications Menu and selected File Manager. Then it prompted which app should be default for file managment. I selected Nautilus and voilà.

  • This is Xfce 4.6.1 installed via these instructions (psychocats.net/ubuntu/xfce). I logged out and back in chosed Xfce as my desktop manager and it has been the default ever since, was this not the way to do it? – jwbensley Jul 27 '12 at 20:56
  • Also You can right click on bottom bar File Manager and select properties then Edit and in command-line write nautilus(not tested, but worth to try) – zuberuber Jul 27 '12 at 21:14
  • 2
    Ok, i think i solved it. edit ~/.config/xfce4/helpers.rc and add FileManger=nautilus – zuberuber Jul 27 '12 at 21:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.