I have a Dell Inspiron 2650 (with NVidia graphics, using nouveau drivers) that I'm using to try out Ubuntu. It's all great, except that Hibernate and Suspend aren't usable.

Yes, I know that questions about power-save issues are rampant in the Linux support universe, but it seems that every time I find a solution it's for a very specific hardware combination and doesn't apply to me. So anyway, here goes.

When I resume from either power-saving mode, I'll get graphics problems anywhere on the range from a few scattered random-colored pixels that won't change; all the way to full-screen patterns that don't change as I move the mouse, hit keys on the keyboard, or even bring up the shutdown dialog using the power button.

Those full-screen issues (which may involve stripes with random pixels, partial black screen, or both) always end in me forcing the machine to shut down by holding the power button.

I haven't done much testing yet to determine what severity level is most commonly associated with each mode, but I do avoid using either power-save option because of these issues.

I'll add info on my hardware as I can gather it (no home internet connection, and this laptop is tethered to my desk by a dead battery and casing degradation). Please feel free to request something specific in the question comments.

Hardware Info

See this hardinfo report for my system's hardware configuration. (No, my username is not "myuser"; I sanitized hardinfo's output before publishing it.)


These screenshots are from a relatively mild occurrence, which happened after the second hibernation I took that session. The first one worked great, though I used the wireless card and Firefox heavily between the two hibernation attempts.

enter image description here

Take a look at what happened when I opened my home directory in Nautilus and scrolled it:

enter image description here

See below for the situations I've tested so far. The real trouble comes when the machine resumes to an unusable state; in such cases I can't even unlock the screen or properly reboot, much less take a screenshot. I have a hunch that putting a CD in the drive will cause such major failures, and I will try that at some point; see related question.

Situations Tested

Maverick (10.10)

  • Seems to suspend nicely with nothing running
  • Seems to suspend nicely with flash drive plugged in
  • On resume from suspend with no flash drive, Terminal and gedit running: Funky graphics on top of log output, then blank screen with pixelated cursor; no response to power button (normally will shutdown 60 seconds later)
  • Seems to hibernate nicely with nothing running
  • Seems to hibernate nicely with a few apps (Terminal, Mouse preferences) running
  • Seems to not hibernate when flash drive plugged in
  • Seems to not hibernate when System Monitor is running
  • Have encountered failed hibernation (after several hours and one successful hibernate/thaw cycle) with no external media connected and no programs running except normal background stuff

Natty LiveCD (11.04_2010-12-22)

When I tested it, Natty wouldn't stay logged in. It played part of the login sound and then [ OK ] appeared in the top right corner (white-on-black terminal text) for a few seconds. Then it kicked me back to the Unlock screen. It did that four times before I gave up and just tested suspend from the Unlock screen.

  • Resumed to vertical gray and black lines 2px (?) wide, then shifted to vertical "jail bars" of black over a black screen with above-described random pixels and mouse pointer. No apparent response to input from mouse (clicking randomly). Keyboard and touchpad unrecognized.
  • use hardinfo to get the system information. Also can you post a screenshot?
    – RolandiXor
    Dec 11, 2010 at 4:37
  • Can you confirm that you have Nvidia graphics and you are using nouveau graphics drivers. If so does a natty liveCD work for you?
    – Andy
    Dec 18, 2010 at 1:21
  • I have added the graphics info to the question. I'll download and test a Natty daily build in the next few days and come back with the results of that. Can I really test hibernate/suspend with a LiveCD?
    – dgw
    Dec 22, 2010 at 23:02
  • Results of suspend test with Natty (2010-12-22) added
    – dgw
    Dec 23, 2010 at 22:49
  • Do you have at least as much swap as you have physical memory?
    – user8290
    Jan 26, 2011 at 14:44

3 Answers 3


This is pretty clearly a bug and not something that should have to be worked around or which could be fixed through user action. The best thing to do in these cases is to open a bug in launchpad so that Ubuntu developers can see it and track it.

For suspend/resume or hibernate problems, it's best to open the bug against the linux kernel. You can do that from a shell by typing:

ubuntu-bug linux

When I upgraded from 10.10 -> 11.04, I had to re-install ACPI.

Here's a debugging guide: https://wiki.ubuntu.com/DebuggingACPI


Ubuntu 20.04 user here. My WIFI tends to fail after resuming from hibernate and enabling hybrid graphics would block hibernation. Plus, regular boot would throw a bunch of ACPI errors before the Login screen appears.

From this hibernation setup guide, I noticed the issue was while I specified the swap file to store the hibernation image in fstab, I did not specify the swap file to resume from under initramfs.

I suspect you already specified where to store the hibernation image in fstab? Then the next steps are to:

  1. Add the same swap partition UUID to /etc/initramfs-tools/conf.d/resume with:
# write the resume UUID (make sure to replace this with your UUID)
echo RESUME=UUID=your-swap-partition-uuid   | sudo tee /etc/initramfs-tools/conf.d/resume
  1. Recreate initramfs with sudo update-initramfs -c -k all

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .