I'm struggling with a very annoying issue: My new hard-drive (Samsung Spinpoint M8 1TB (HN-M101MBB) was build in an USB 3.0 external case (Lian Li EX-10QR) and formatted with ext4. When this hard-drive is connected to my Notebook via USB 2.0 it "klicks", the LED flashs too, every second, but only when it's idle! It stays silent, when something is copying or reading from it. But when this drive was formatted with ext3 or fat, it always remained silent.

This also happens with a Western Digital WD10JPVT Scorpio Blue, but the "klicks" are even louder!

System: 12.04 64-bit with Gnome-Shell.

Any ideas how to approach this issue?

closed as off topic by Anwar, SirCharlo, con-f-use, RobotHumans, Mitch Aug 22 '12 at 14:59

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • This issue is more closely related to hardware rather than Ubuntu, and as such, I think, this is off-topic here. You can use Superuser.com to ask this kind of questions. – Anwar Jul 27 '12 at 17:04
  • 2
    @AnwarShah I'm not so sure this is off-topic. user79691 is asking now to approach this issue using Ubuntu. In other words, it's a question about how to use Ubuntu for a particular task (of figuring out the problem, fixing it if posible, and presumably backing up otherwise). – Eliah Kagan Jul 27 '12 at 17:28
  • @Eliah Kagan: You are totally right! – DMT Jul 27 '12 at 17:39
  • You should test another USB 3.0 enclosure from a different maker. If the issue persists, it's likely not to be an issue with how the chipset of the enclosure handles power management. – LiveWireBT Jul 27 '12 at 19:39
  • It seems, that it's not the enclousures fault, because under ext3 and fat32 the disk remains silent. – DMT Jul 28 '12 at 9:51

As I have written before I received my USB 3.0 enclosure today and experienced the same issue with a drive which has been operating fine in another enclosure for quite some time. I have 4 partitions on that drive: one swap, one NTFS and two EXT4. The first EXT4 partition has Ubuntu installed on it, the second was a fresh formatted partition and only the second one caused the drive activity. After some experimenting I looked into iotop and saw a process being active on the partition. It turned out to be the journaling process for that drive and after some minutes in idle the drive completely stopped activity. I have transfered 50 GB to the drive and it's silent again after the copy job finished. I believe it just had to build the journal or finish some other maintenance activity after the partition was formatted. I also tried a regular micro USB cable when the drive was busy in idle state with the same result, so it's not a USB 3.0 issue.

  • The same goes for me. After copying 300 GBs on the external hard-drive, the clicking finally disappeared! Thank you LiveWireBT for finding this out! – DMT Aug 18 '12 at 15:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.