I had the following issues with my Sony Vaio E14115's touchpad on Ubuntu 12.04:

  1. Right click not working
  2. Vertical scrolling not working

Then I followed these steps to fix it:

  1. Downloaded a patch for Psmouse
  2. sudo apt-get install dkms build-essential
  3. cd ~/Desktop
  4. tar jxvf psmouse-3.2.0-24-generic-pae.tar.bz2
  5. sudo mv psmouse-3.2.0-24-generic-pae /usr/src
  6. cd /usr/src
  7. sudo chmod -R a+rx psmouse-3.2.0-24-generic-pae
  8. sudo dkms add -m psmouse -v 3.2.0-24-generic-pae
  9. sudo dkms build -m psmouse -v 3.2.0-24-generic-pae
  10. sudo dkms install -m psmouse -v 3.2.0-24-generic-pae
  11. sudo modprobe -r psmouse
  12. sudo modprobe psmouse

This fixed me the problems of Rightclick and vertical scrolling.

But I still have an issue of not able to click and drag ie Clicking the leftmouse button and dragging with another finger. It doesn't move! Maybe it doesn't detect the 2nd finger.

When I check the capabilities of my Synaptics touchpad by using

xinput list-props "SynPS/2 Synaptics TouchPad"|grep Capabilities

I get the following output:

Synaptics Capabilities (304): 1, 1, 1, 1, 1, 1, 1

Please help me out.

  • Can you click with the touchpad and then drag? (EX. Tap finger twice and on second tap keep finger on pad and then move it.)
    – user78723
    Jul 27, 2012 at 7:09
  • @MatthewKaulfers Yes..I can do that. But I am more accustomed to clicking and holding down the left button with my left hand dragging with my right hand.
    – Nabeel
    Jul 27, 2012 at 15:28
  • okay you seem to be having a driver issue. Go to settings>additional drivers and see if it comes up with anything. But that is definitely your problem. If it doesn't come up with anything I might suggest going to the Vendor (Sony Vaio) and see if they have a linux driver available. (Chances are they do)
    – user78723
    Jul 27, 2012 at 21:10
  • Only some ATI radeon graphic drivers come up in the Additional drivers. VAIO's site only has drivers for Windows! :( nothing has been mentioned about running on the linux platform.
    – Nabeel
    Jul 28, 2012 at 16:38

2 Answers 2


I wrote a blog on configuring touchpad on my lubuntu set-up for the netbook. I wanted to disable tap to click but I link to instructions and you can try whichever suit you. It should work on other distros fine but I have only tested it on lubuntu.

how to set a config custom touchpad configuration


I couldn't test your patch solution as you have not provided the link to the patch you used. However, I found that the following from this answer worked for me on my SVS1511:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

This restored right-click and vertical scrolling for me. To make this permanent, create /etc/modprobe.d/psmouse.conf and put this line in it:

options psmouse proto=imps

That should ensure the option is loaded at boot. No patching of psmouse is necessary.

  • Worked for me on Vaio SVF... Gnome Tweaks did not...
    – The Wise
    Jul 24, 2019 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.