No support for this USB broadband modem. Does anyone have a clue on how to enable or install it in Ubuntu 12.04?

The device is listed by lsusb as 2001:a80b but in network manager, there is nothing in there.

Device is detected in /dev/sr1 or sr2 and can be mounted with

#mount /dev/sr1 or sr2 /media/<mkdir your own directory>

It contains various files. A file named "dlinkusbmodem.deb" is present. Double clicking opens it in Software Center but gives error during installation. Figures it is a 32-bit driver for 32-bit OS. Please help.

  • Please have a look here for some tips and tricks: askubuntu.com/questions/14008/… – Rinzwind Apr 22 '12 at 11:06
  • Does it have a Linux Driver? I had a DLink modem when I emailed them about the driver Issue They told they dont have Linux Drivers. But still they listed in lsusb – Sreevisakh Apr 22 '12 at 12:32


Before proceeding ahead, I would say that I used ultimate edition linux 3.4 64 bit-- this distro has all the library and dependencies for installing drivers( ia32-libs, usb_modeswitch).

The driver supplied with the dongle is a 32 bit driver. This successfully gets installed on a 64 bit Ubuntu if, and only if you have ia32-libs installed.

I used this driver with Lubuntu 64 bit and got an error message when I ran the command:


The error was /usr/bin/usbdeviceswitchdlink: command not found.

The work around is simple. At the terminal (Ctrl+Alt+T) type this:

sudo su

And enter your password. Then type:

apt-get -y install ia32-libs

The above command will add 32 bit compatibility on 64 bit Ubuntu successfully. If you get an error message, run the command again.

Once successfully installed, proceed ahead and you shouldn't get any error messages once you have installed the 32 bit driver on your 64 bit Ubuntu.

In the terminal, type usb then press Tab twice. If you don't see usb_modeswitch, it means it is not installed - good, you don't need it. If yes (you see it), you need to uninstall usb_modeswitch.

Step 1

  1. Type sudo su, and enter your password.
  2. Then type:

    mkdir /media/cdrom
    mount /dev/srX     /media/cdrom 

    Press Tab twice.

    Note: the X in /dev/srX must be 1 or 2 - use accordingly.

  3. Once mounted, press Alt+F2, and type nautilus. You will see the cdrom mounted on the left. Click it.

  4. A file dlinkusbmodem.deb should be present. Double click it. Install it.

Step 2

After the installation is complete, type the following in the terminal:


It will show command executed successfully.


I'm using this dongle with Reliance netconnect 3G.

And here's the video.


In case you are not able to mount the device (in Step 1), there is an alternative:

  1. Connect the device to a Windows PC. (Do not install the Dlink.exe. If already installed, uninstall it.) Then reconnect the device. It will show up as a USB storage device.

  2. Browse it and copy the file dlinkusbmodem.deb (our driver) to any storage device.

  3. Go back to your Ubuntu and paste the file to your Desktop and install it by double clicking it. If it gives you errors, go to the terminal and type the following command:

    cd ~/Desktop && sudo dpkg -i dlinkusbmodem.deb 
  4. The drivers should be installed. Now continue following the instructions in Step 2.

I tied it in crunchbang linux (a debian based Linux OS) but with no luck. I got an error regarding wrong architechture when I force install it! Strange, it works flawlessly on Ubuntu 12.04 64 bit and without the --force-architecture parameter.

WARNING!!: Modem connection and disconnection regression- typical of usb 3g modems will occur if you run

sudo apt-get update

be WARY when you run the above command, as your modem might start getting disconnected when you enable the network!

If it occurs, reinstall the drivers after purging them fully. This effectually will solve the problem. Follow the above steps to install.


Just want to bring to your attention:

If you insert your 3G SIM card in the dongle, you might get instant connection. After a certain period of time and usage, the dongle will get disconnected! I had taken a 3GB FRC pack for first usage. I spent a few days with this problem until I went to the showroom of my service provider where he stated: the data used up to 1GB is at the customers discretion. Once that data is used your connection cuts because your IMEI no. of the dongle goes in for verification (to check whether the device has a valid and not stolen IMEI). This procedure can take up to 3 days. After three, days I called the tech support of my service provider and they confirmed it will take another 2 days for the connection and the rest of the 2GB usage back. I continuously got "MODEM DISCONNECTED" error while using the 3G SIM card with this dongle. This is a typical problem most USB modems have and I thought it's the same thing...until I inserted my 2G SIM card and got the connection instantaneously! I had a 2G connection in my phone's SIM and I got a 18kB/s sustained download speed with this dongle. All problems solved.

Now, for the fun part:

Using the 3G connection using this dongle on my Lubuntu 12.04 netbook and connecting to my wireless TP-LINK N 300 router to get internet connection to all the computers on the network.

3G dwm 156 DONGLE -->> LUBUNTU NETBOOK -->> ETHERNET PORT OUT -->> CAT5/CAT6 CABLE -->> WAN PORT OF TP-LINK WIRELESS N ROUTER -->> GETTING INTERNET CONNECTION ON 4 ROUTER PORTS AND WIFI -->> getting connection on my desktop computer using D-link wifi dongle DWA 131.

Here is the procedure:

  1. From my Lubuntu 12.04 netbook, enable 3G connection using dwm 156 and check internet connection.

  2. Connect my ethernet port of my netbook to wan port of router.

  3. Open network-manager on netbook.

  4. Go to wired connection 1 (eth0) and press the edit button.

  5. Go to IPv4 settings: enable- "shared to other computers".

  6. Save.

  7. Reboot the router and netbook.


NOW if you get connection-disconnected error do the following:

Open a terminal and type:

sudo su

And enter your password, then type:

killall  dnsmasq


If need be, check your router's wan IP settings.

Now I'm sharing internet connection using D-link DWM 156 with 7 computers.

  • I installed the my device (DWM-156) using the steps described above, but when run usbdeviceswitchdlink command I receive following error: ile : usbdeviceswitchdlink.c starting......................vid:8193 pid: 32000 vid:32903 pid: 32 vid:7531 pid: 2 vid:16700 pid: 33120 vid:16700 pid: 33122 vid:16700 pid: 33121 vid:2652 pid: 17664 vid:3141 pid: 25629 vid:32903 pid: 32 vid:7531 pid: 2 right_dev usb_open Error: could not access device. Aborting any help? – PHP Learner Sep 27 '13 at 16:36


First of all, it sounds like your hardware isn't currently supported, so your best option would be to file a bug report by running ubuntu-bug linux (this should gather some information about your system). If the developers don't know about your problem then they won't be able to make the hardware work out of the box.

From what you've described, it sounds like your modem is a "mode switch" style device. These devices pretend to be a storage device holding the Windows drivers when plugged in. The Windows drivers send a special command to the device that causes it to reset and provide a different set of capabilities.

It is likely that Linux has a driver that can handle the device after the reset, but just doesn't know how to perform the reset.

The usb_modeswitch command is responsible for performing this job, but it doesn't appear to have any configuration for your device. There is configuration info for two other D-Link DWM-156 devices with different USB IDs though, and they appear to use the same mode switch message, so it might be worth sending that message and see what happens. The following command should achieve this:

sudo usb_modeswitch -v 0x2001 -p 0xa80b --message-content 5553424312345678000000000000061b000000020000000000000000000000

With any luck, your device may have changed USB IDs and may even have a driver bound to it. The device might even be visible to NetworkManager at this point. If you're unlucky, the device might hang and need to be unplugged and replugged.

If this does work, include the command in your bug report along with the USB vendor/product IDs of the device before and after the switch.


For ubuntu 13.04: same procedure as 12.04. Just be sure to do the following:-->

Uninstall usb_modeswitch completely from your system(do it from command line or software centre)

Install ia32-libs on a 64 bit install of 13.04(around 84MB of downloads required)

sudo apt-get install ia32-libs

Follow the steps from 12.04 for the rest..


Dont know if this is helpful.. THe dwm-156 is plug n play with tplink mr3420. The dwm-156 is plug n play with tplink mr3020 but with the latest BIOS update from tplink website.

protected by Community Aug 5 '12 at 19:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.