My Sony Vaio T11 does not have a hardware button to enable/disable wifi. When I disable wifi in NetworkManager and reboot "enable wireless" is not available (grayed out) in Networkmanager.

$>rfkill list wifi
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: sony-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes

Different to similar problems of this kind "rfkill unblock all" does not help. However I can boot into windows, start the wifi there and when I reboot to linux wifi is working again.

  • Please post output of lspci -vvv & sudo lshw -class network
    – Web-E
    Jul 27, 2012 at 3:42

1 Answer 1


Using the NetworkManager command line tool to enable wifi solved my problem:

nmcli nm wifi on

Seems like the NetworkManager believed that the hardware switch was turned off and dimmed the "enable wireless" due to that "wrong" information. However forcing to enable wireless with the command line tool worked.

  • I have spent many hours looking for this, Thank you so much. May 15, 2013 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.