5

I just set up a fresh install of Ubuntu 12.04 on my VPS, and I cant for the life of me install or even locate MySQL server..

apt-cache search mysql 

gives no results on mysql-server/mysqld-server

apt-get install mysqld-server 

as well as many variations just gives the output in the title:

unable to locate package mysqld-server

I have added the universe repo, in which it should be located, but nothing. Google yields absolutely nothing on this, the only relevant info is just to run those commands, and to run another that is supposed to work:

apt-get install Lamp-server^ 

(may be misspelled a bit, but its close and I ran the correct one earlier) which also didn't work at all, it said the same thing, unable to locate package "etc"

Am I missing something here? should I have a specific repository I don't? should I be running a different command? or did ubuntu 12.04 drop mysql support or something?

Thanks for your time guys, hope I can get this to work, its driving me crazy.

9

You want to install mysql-server, which does exist in 12.04.

If you can't find it maybe you've done a clean install and haven't done an update yet, so do the following:

sudo apt-get update
sudo apt-get install mysql-server

If that doesn't work update your question with what happens.

| improve this answer | |
  • Wow. Thanks. I dont know why that didnt work the first time around..? I ran "apt-get update" right after I updated my sources.list, so thats quite strange that it didnt even show up in the apt-cache... hmm. That makes me feel quite dumb.. but still it really is weird to me that it didnt show up in the cache even thought I already updated, I wonder what changed from me logging out and logging back in, without doing anything else besides the commands I listed. Thanks alot Jorge, I appreciate it. – insomnia Jul 26 '12 at 22:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.