I have used Universal-USB-Installer ever since to install different Linux versions to USB flash drive. But now with Lubuntu 12.04 even though I do the same process by selecting persistence file, it gets created but is never used in Lubuntu. Every time I boot into Lubuntu on flash, it is fresh new Lubuntu without my changes I did last time I have booted it.

Anyone can help me or give me some hints ? Thanks in advance.

  • Well this is not an answer, but more data on the error/feature. While trying to install Ubuntu 12.04.1 I get persistence for both unetbootin and UsbDisk Creator in the user directory (ie echo Stuff > hello.txt, on the next reboot 'hello.txt' and its contents are still there). If I edit a system file (such as 'sudo vi /etc/hosts') it is not persistent. I don't know if this is because of the super user or the location of the file. Oddly it does remember chmod and chgrp, chown to user 'ubuntu', but not the contents of the file. So I think this is a 'feature' of /cow (casper?) – user95450 Oct 8 '12 at 20:54

Previous answers only quote one of the two parameters needed by a live *Buntu to have a working persistence auto activated. Below was tested with Lubuntu/Ubuntu 14.04.1:

  1. The syslinux menu (or grub.cfg if GRUB2 is used) must have "persistent" (not "persistence") added as a kernel boot parameter as @Jason pointed it out:

    • Example for syslinux:

      append  file=/preseed/lubuntu.seed boot=casper persistent initrd=/casper/initrd.lz ...
    • Example for grub2:

      linux /casper/vmlinuz file=/preseed/ubuntu.seed boot=casper persistent quiet splash ...
  2. And the Flash-device's partition that is reserved for persistent data must be labelled "casper-rw" This is achived with a nice GUI tool such as gparted, or in command-line, eg:

    mkfs.ext2 -L casper-rw -m 0 /dev/sd<FLASH-DEVICE-PARTITION-FOR-PERSISTENT-DATA>

Please try creating the persistent USB with Unetbootin; we've seen many problems with the Universal Installer here.

Note that I tried with Lubuntu 12.04 and persistence works perfectly for me:

enter image description here

  • The persistent partiion /cow above is 256MB, and it works as expected. You can check for its presence on your Lubuntu...
  • I have tried Unetbootin, but when I boot from USB, it boots and after few seconds it displays Lubuntu splash screen with white and blue dots underneath changing. And its stucked on this screen and never proceeds to desktop screen. Any hints about that ? – Frodik Jul 26 '12 at 15:39

After using Universal-USB-Installer, you will need to modify txt.cfg and text.cfg to include persistent at the end of each of the boot lines ending with "--"


..... boot=casper quiet splash -- persistent

My guess is that Universal-USB-Installer fails to add "persistent" to the end of the cfg files during the installation process.

  • 1
    txt.cfg and text.cfg are both in the syslinux directory – Jason Dec 4 '12 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.