I updated my Ubuntu 12.04 last night to the latest packages.

When I tried to change brightness using Fn Key this morning, brightness went all the way to either min or max brightness. I was not able to set brightness to anywhere in between.

I thought the update may have broken Fn Key, then I tried using the slide in Brightness and Lock screen in system settings. But when I have Brightness and Lock opened, brightness is locked to min brightness no matter I use the slide or Fn key.

P.S. I had no problem with brightness before yesterday.

My hardware is Samsung NP350 Laptop with Intel HD3000.



I had the same issue, and was able to solve it as follows. In a Terminal (Ctrl+Alt+T) I ran:

cd /etc/modprobe.d

I looked to see what files the /etc/modprobe.d directory contained:

porsche@porsche-300V3A-300V4A-300V5A-200A4B-200A5B:/etc/modprobe.d$ ls -la
total 52
drwxr-xr-x   2 root root  4096 Aug  4 00:33 .
drwxr-xr-x 131 root root 12288 Aug  4 00:54 ..
-rw-r--r--   1 root root  2507 Feb 15 21:03 alsa-base.conf
-rw-r--r--   1 root root   325 Mar 18  2011 blacklist-ath_pci.conf
-rw-r--r--   1 root root  1656 Aug  4 00:33 blacklist.conf
-rw-r--r--   1 root root   210 Mar 18  2011 blacklist-firewire.conf
-rw-r--r--   1 root root   661 Nov 20  2011 blacklist-framebuffer.conf
-rw-r--r--   1 root root   156 Feb 15 21:03 blacklist-modem.conf
lrwxrwxrwx   1 root root    41 Jul 31 13:04 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r--r--   1 root root   583 Mar 18  2011 blacklist-rare-network.conf
-rw-r--r--   1 root root  1077 Mar 18  2011 blacklist-watchdog.conf
-rw-r--r--   1 root root    30 May 18 03:03 vmwgfx-fbdev.conf

So I edited blacklist.conf by running sudo vi blacklist.conf. (You can also use sudo nano -w blacklist.conf or gksu gedit blacklist.conf.)

I added the following lines to blacklist.conf:

blacklist samsung_laptop
blacklist samsung_backlight

Then I saved the file, and quit the text editor. Afterwards, I applied:

sudo apt-get update

I restarted my laptop and everything is OK right now.

  • 1
    sudo apt-get update updates information about what packages are available to install. Running that won't stop this from working, but it is not related at all to what modules get loaded into the kernel (unless it is followed by commands that install a new kernel package or upgrade an existing one). It can simply be omitted. – Eliah Kagan Aug 4 '12 at 18:50
  • Thanks Jorge, it worked like a charm. As Eliah commented, no update is necessary. Just add the two lines to blacklist.conf file, save and reboot, problem solved. – David Aug 5 '12 at 23:18

Try Running Update Manager. Install any and all packages. THEN REBOOT! If this does not work, Try again in a week. If that does not fix it wait for a few weeks and try again. If still this does not fix it I do not know what to say. This is why I do not recommend upgrades. Instead you should re install, start from scratch.

  • Rather than waiting 4 weeks hoping someone will fix the problem, it's better to report the bug as Jorge Castro has recommended. – Eliah Kagan Jul 26 '12 at 16:51

Im facing the same issue after the system update in a samsung Laptop with the same video adapter. I notice when you reduce the bright with the fn key or through the configuration, the problem appear and the X session crash. Looking forward for a solution. As temporal solution, remove the Dim screen to save power from Brightness and Lock.


Notebook NP530U3B:

cat /etc/madprobe.d/blacklist-samsung.conf
blacklist samsung_laptop
blacklist samsung_backlight  #if you have
  • 1
    cat does not edit a file. If you're saying the blacklist lines should be added to the file, I recommend editing to clarify that, and explaining how to properly edit it. If you're saying something else, I recommend editing to clarify what that is. – Eliah Kagan Aug 18 '12 at 2:35

I had the same problem and fixed it easily as follows:

  1. Restart your machine and press "shift" until the "grub" menu appears
  2. Choose previous linux installation
  3. Choose the kernel version which was just before the last update.

When ubuntu boots, everything should be OK. You need to do this everytime you restart your machine until the bug is fixed in future kernel versions. It seems the latest kernel update had an issue!

  • I just tried boot into previous linux versions and it works as expected, however it just hang there when hibernate. Removing Dim screen to save power didn't work for me. So for now, I think I would just use max brightness when connected to AC and min brightness when on battery. – David Aug 2 '12 at 2:23

The problem is in the new kernel that was installed after you update your system. Just open a terminal window (Ctrl+Alt+T) and type:

gksu gedit /boot/grub/grub.cfg

In the newly opened text editor window you need to comment lines to refer the new kernel (I guess is the version) and stil uncommmented the old version ( Just save the file and reboot your system, that worked for me and probaly will work for you too!


This Solution is working for me. I hope it would help you.


I had the same problem on my samsung (QX410, different model). This was fixed by the 3.2.0-31 kernel, so you may want to update again and see if it's gone away.

Here's the bug report:


Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.