I just figured out today that as long as the battery is in my laptop, it doesn't matter if it's fully charged while plugged in, Ubuntu always spins down my hard drive. I noticed this because there was a huge difference in speed when I removed the batteries.

My settings for power management is basically:

  • on AC power, don't spin down harddrive, dont suspend or anything
  • on battery power, basically save as much power as possible

I assumed that if I plug in my laptop, it'll use the On AC Power settings no matter what but apparently, this isn't so. Is there a way to "fix" this?

closed as off topic by jrg May 22 '12 at 18:46

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.


You could try editing these settings in gconf-editor:

gconf-editor /apps/gnome-power-manager/disks

I think you need to eliminate if you have a battery problem. If you remove the battery and just run on the charger and the problem goes away it could be a battery that is pulling too much current and the system would go bonkers because the little external charger can't handle the load. You can check the battery by giving it a full charge then run on battery in Windows if you have Dual boot or a live CD other than Ubuntu. If you still have the problem it is probably the battery. If not it's likely a software problem. Good luck. Maury

Not the answer you're looking for? Browse other questions tagged or ask your own question.