3

I tried installing VIM using terminal command sudo apt-get install vim but it didn't install and I got this message:

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:  flashplugin-installer   : Breaks: flashplugin-downloader (< 11.1.102.55ubuntu3) but  
11.0.1.152ubuntu1 is to be installed
vim : Depends: vim-common (= 2:7.3.429-2ubuntu2.1) but 2:7.3.429-2ubuntu2 is to be installed  
      Depends: vim-runtime (= 2:7.3.429-2ubuntu2.1) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install'  with no packages (or specify a solution

I tried using apt-get -f to install, but it didn't work.

How can I fix it?

  • 1
    Did you update the package database? sudo apt-get update; sudo apt-get upgrade – jmetz Jul 25 '12 at 18:25
  • Yes, but I get the same errors trying to install VIM – SDsolar Jun 21 '17 at 6:43
12

probably answering this too late. but try uninstalling vim-common too. I was facing a similar problem with the error message

The following packages have unmet dependencies:
 vim : Depends: vim-common (= 2:7.3.429-2ubuntu2) but 2:7.3.429-2ubuntu2.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I was able to solve it by uninstalling vim-common package first.

sudo apt-get remove vim-common

After that i was able to install it with no problems.

8

What I see there is that the flashplugin-installer package had some kind of downloading or installing problem and it is not letting you install vim. What I suggest is remove the flashplugin package, then do a refresh of the repository cache and then download vim. Afterwards just install flash again, although I recommend doing it via the restricted extras. Something like the following:

sudo apt-get remove flashplugin-installer
sudo apt-get update
sudo apt-get install vim
sudo apt-get install ubuntu-restricted-extras

On another note I actually still recommend using aptitude over apt-get. Or even synaptic to solve in an easy manner multiple conflicting problems between packages.

4

I would like to combine both of ur answers. Type it one by one:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get update
sudo apt-get remove vim-common
sudo apt-get install vim
0

I realize this was posted more than 4 years ago.

So here in June 2017 I installed lubuntu 12.04

I had all these same problems.

I tried everything listed in all the answers I could find but could not get vim nor vim-nox to install.

So you can just imagine my surprise when I typed in

vi

and it came up with the vim screen in color.

I am embarrassed I spent an hour trying to force the install only to discover that it is already there.

That explains why the vim-common had a version problem.

  • vi !== vim ... So technically you do not have vim installed if you are using vi alone. – azatar Jan 19 '18 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.