6

Ok so I tried for the first time to use PGP keys for email encryption in Evolution. I followed some instructions online, created a key, but coz I encountered some problems I decided to delete the key and restart the proces. (This fact is probably irrelevant, because I got similar errors when doing it.)

Now I have no key and I go to Remote: Sync and publish keys. Firstly it says that there are 6 keys selected for synchronisation. Why? I do have some passwords saved in here, will it sync those too??

And last, when I click sync I first get two errors:

Couldn't retrieve keys from server: pool.sks-keyservers.net

Couldn't communicate with server 'pool.sks-keyservers.net': Internal Server Error

and

Couldn't retrieve keys from server: keyserver.ubuntu.com:11371

Couldn't communicate with server 'keyserver.ubuntu.com:11371': Internal Server Error

Than the progress stops and no progress is made, it just says:

Synchronising keys... Exporting data

Any help?

7
  • 1
    Can you post the keyservers available in seahorse , through the same sync option menu.
    – atenz
    Commented Jul 25, 2012 at 14:58
  • 1
    hkp://keyserver.ubuntu.com:11371, hkp://pool.sks-keyservers.net and ldap://keyserver.pgp.com these are the keyservers i have by default. Commented Jul 25, 2012 at 15:33
  • They are right , have you tried revoking them. do you have any firewall like UFW installed and enabled.
    – atenz
    Commented Jul 25, 2012 at 15:53
  • Because I wanted to start over(and some error in evolution about public key), I deleted all keys in preferences. Regarding the firewall- I have a pretty much clean install and have not messed with firewall preferences, but I think it is on by default in ubuntu? Commented Jul 25, 2012 at 16:05
  • Then not a firewall issue. have you integrated pgp to evolution mail.
    – atenz
    Commented Jul 25, 2012 at 16:36

4 Answers 4

5

I had the same problem. I fixed it by:

  1. Remove all existing keyservers from the Sync box (by default hkp://keyserver.ubuntu.com:11371, hkp://pool.sks-keyservers.net, and ldap://keyserver.pgp.com).
  2. Add them over again (keeping the same settings).
  3. Press Sync.

Don't know why this works, but it does.

3
  • Hey" I tried removing and adding back keyservers, but the problem still persists. Commented Aug 12, 2012 at 11:27
  • I am using Xubuntu 18.04 and there hkp://keyserver.ubuntu.com:11371 is added by default. I wonder why?
    – jarno
    Commented Nov 24, 2019 at 20:41
  • Does not work for me unfortunately
    – Axe
    Commented Apr 15, 2020 at 5:58
0

Another workaround is to go directly to https://keyserver.ubuntu.com/ and submit the ASCII-armored version of your key.

You can generate it like this:

gpg --armor --export [email protected]
0

One of the following approaches worked for me, I'm not sure if the first will fix it but I will certainly encourage for the 2 approach.

This anwer was inspired by both @Pranesh-Prakash and @ConorSheehan1 answers.

  1. Using Password & Keys GUI app, go to Preferences, and activate the checkbox for Automatically synchronize modified keys with key servers. Retry sync

If the synchronization fails then try this:

  1. Using Password & Keys GUI application, go to Preferences.
    • In the Keyservers section, add a new one using the Add keyserver button
      • Select HTTPS as the Key Server Type.
      • Add keyserver.ubuntu.com (no protocol, no port) as HOST
    • (My current version of Password&Keys doesn't update automatically to reflect the changes so I have to close Preferences and re-open it for the next step)
    • In the Key Synchronization section, from the Publish keys to drop down list select the new keyserver you just added.
    • Close preferences and try sync
-1

Try this solution from ubuntuforums. http://ubuntuforums.org/showthread.php?t=1726418

gpg --gen-key --enable-dsa2

Hope this helps!

2
  • 1
    How would this be helping the user? This isnt the user's issue, his issue is syncing the keys, not creating a key.
    – Thomas Ward
    Commented Jul 25, 2012 at 14:04
  • Agreed. I can create the key without a problem. Commented Jul 25, 2012 at 15:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .