I have two keyboard layouts: Hebrew and English. The preferences are set to allow different layouts for individual windows and to open new windows with the default layout, but it doesn't work that way, and it's a little hard to explain exactly what happens. Sometimes it switches the layout to all windows. sometimes it opens a new window, shows the previously active layout (rather than the default), then when you minimize the window and maximize it again, it's on the right layout. Sometimes it displays that one layout is selected, but the actual typing is in the other layout.

I believe that there are separate and overlapping problems in the keyboard layout settings and the keyboard layout indicator. They do not seem to communicate and work together properly, and the result is very confusing.

I'm certain this is a bug, and I'd report it, except I'm not sure about two things: one, whether there's already such a bug report or not. I've been searching one for a while, and I remember seeing something, only I can't find it now. Two, which packages are responsible for the keyboard layout, that is, which packages should be reported. Has anyone seen this before? Found something on Launchpad? Has a fix? If not, what packages are likely to cause this?

  • I sometimes have to use regional languages on Ubuntu, and I use SCIM for that. SCIM is an English input method that lets you write in regional languages using English input method. You could use Ibus which is recommended by Ubuntu. – Srinivas Gowda Jul 25 '12 at 13:13
  • I changed to Ibus on the language support menu. Logged out and back in, and it seems to be using that. However, it still has the same behavior. The separate Ibus settings seem to have no effect on the keyboard layout settings. Now I am even more confused. :( – Amir Adar Jul 25 '12 at 18:51
  • I think I see now. Ibus is used as an extra input method switcher which is only activated when a combination is pressed. That would work, I suppose, but there are a few problems with that. The first isn't serious, but having two keyboard icons on the panel is not ideal. The second is that I can't seem to be able to use Ibus with Hebrew, only with two kinds of Chinese. Is there something I'm missing? – Amir Adar Jul 26 '12 at 11:58

After messing around a bit, I realized the difference between keyboard layout and keyboard input methods. I removed the Hebrew keyboard layout, thus removing the layout indicator from the panel. I installed m17n for Ibus, and that gave me the option to select a Hebrew input method. I changed the activation of Ibus to Shift+Alt, and disabled having the same input for all applications.

It works exactly as I want it now. It's unfortunate that I had to do all this research to get such a simple function to work properly. The keyboard layout switcher should be fixed to behave according to the preferences. It will solve a lot of problems. Thank you, Srinivas, for putting me in the right direction. :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.