I have solved it. It is necessary to install the latest binary from the "development" folder, extract the only file called "biber" and copy it to "/usr/bin".

The binary of the latest stable version 1.0 will not work though and show this error.

slazer@peter:~/Downloads$ tar xvf "biber-linux_x86_64(2).tar.gz" 
slazer@peter:~/Downloads$ ./biber
data source /tmp/par-736c617a6572/cache-fb3144567cd1381b403b18600c1ec4b232b2c018/inc/lib/Biber/LaTeX/recode_data.xml not found in .
Compilation failed in require at Biber/Utils.pm line 20.
BEGIN failed--compilation aborted at Biber/Utils.pm line 20.
Compilation failed in require at Biber/Internals.pm line 8.
BEGIN failed--compilation aborted at Biber/Internals.pm line 8.
Compilation failed in require at (eval 22) line 2.
    ...propagated at /usr/local/perl/lib/5.14.1/base.pm line 94.
BEGIN failed--compilation aborted at Biber.pm line 5.
Compilation failed in require at script/biber line 20.
BEGIN failed--compilation aborted at script/biber line 20.

What could be the problem? I have 64 bit Linux.


In case anyone has trouble with more recent versions, the following worked for me, for Ubuntu 14.04 (trusty):

First, I completed a 'vanilla' install of TeXLive as per the instructions in the link.

Then simply:

sudo apt-get -y install biber

This currently installs version 1.8.

Everything appears to work fine with this, including AucTeX.

|improve this answer|||||
  • Works even for 16.04 LTS – Tejas Shetty Aug 28 '19 at 13:52

To install Biber, you can do so from the Ubuntu Software Center. By clicking below:

|improve this answer|||||
  • 2
    This is, however, only for Ubuntu 12.10 (Quantal Quetzal). When I click it, the Ubuntu software center does not find the package. – Slazer Jul 25 '12 at 10:25

Ubuntu 12.04 uses biblatex version 1.7-1; you can verify this by running:

apt-cache show biblatex

According to the biber documentation, the last biber release to support biblatex 1.7 is biber 0.9.9.

You can download the appropriate version of biber 0.9.9—32bit or 64bit—here: http://sourceforge.net/projects/biblatex-biber/files/biblatex-biber/0.9.9/binaries/Linux/

|improve this answer|||||

Although there is no biber-package for ubuntu 12.04, you can go ahead and install the one from ubuntu 12.10. It is still available at http://old-releases.ubuntu.com/ubuntu/pool/universe/b/biber/biber_0.9.9+release-1_all.deb. After installing it with dpkg -i the dependencies can be pulled via apt-get -f install.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.