41

Using ubuntu 10.10 the editor in mc (midnight commander) is nano. How can i switch to the internal mc editor (mcedit)?

63

Press the following keys in order, one at a time:

  1. F9 Activates the top menu.
  2. o Selects the Option menu.
  3. c Opens the configuration dialog.
  4. i Toggles the use internal edit option.
  5. s Saves your preferences.

alt text

  • 6
    Can you also add how to change the editor to any other editor? – trusktr Nov 4 '12 at 20:34
  • It would be better to specify a way to change this from the command line, but not by changing the OS default editor. – sorin Apr 30 '13 at 8:10
  • This is great, but is there a way to do the same in the command line, say, by adding/changing an environment variable? I'd like to automate this. – Nickolai Leschov Apr 5 '14 at 17:34
  • 2
    Looks it has changed to 't' instead of 'i' image – pshirishreddy Feb 15 '16 at 5:43
34

Run MC as usual. On the command line right above the bottom row of menu selections type select-editor. This should open a menu with a list of all of your installed editors. This is working for me on all my current linux machines.

  • Thank you! That was the only solution that worked for me with the mc version in the Ubuntu 14.04 repositories. – Sledge Hammer Aug 9 '15 at 11:57
  • 3
    Doesn't work for me. I get a "Command not found" error from Bash. – marlar Mar 17 '16 at 8:50
13

You can also change the standard editor. Open a terminal and type this command:

sudo update-alternatives --config editor

You will get an list of the installed editors on your system, and you can chose your favorite.

  • 2
    OP is not asking how to change the system default editor. – Ryan Thompson Dec 9 '10 at 18:33
2

If you want to leave mc and system settings as it is now, you may just run it like

$ EDITOR=mcedit mc
1

Open Midnight Commander, go to Options -> Configuration and check "use internal editor" Hit save and you are done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.