OK I'm currently trying to install Ubuntu x64 Server 12.04 onto the following machine:

  • Intel Core i5-2320 3.0GHz LGA1155 6MB
  • 8 GB DDR3 RAM,
  • Gigabyte Z68P-DS3 S1155 Intel Z68 DDR3 ATX M/B,
  • OCZ 60 GB SSD,
  • 3x Samsung 2TB drives in a RAID 5 array (via M/B)

Now what I think is causing the issue is the following:

EVGA GeForce GTX 550 Ti 951MHz 1GB PCI-Express HDMI FPB

As the server CD works in text mode I haven't had a problem with actually installing Ubuntu.

Partioned with:

  • 1GB /boot SSD,
  • 59GB / SSD,
  • 10GB swap RAID5,
  • ~4TB /home RAID5

On a straight boot, you briefly see the GRUB menu, followed by a blank screen. The keyboard and mouse blink as they are initialised but no sign of life from the screen.

Followed by a bit of research (otherwise known as google) ...

Booted in quiet splash nomodeset

Now I have a fully working linux distro at the command prompt. I then proceed to try and update the nvidia drivers with apt-get (after updating repositories etc) and rebooting. Still the same problem. I also tried reinstalling from the CD and installing said drivers in the install process before GRUB was installed, still the same symptoms.

Does anybody have any solutions? I'm at my wits end here, I bought this machine to be a linux server / tinkering machine and have just spent 4-5 hours trying to just get a basic install working.


OK after me and Matthew conspired (see below) the following was done:

I had an onboard video (via the i5), stripped out the GTX550 and reinstalled linux.

Once linux was installed, I then had to install the ubuntu desktop:

  1. sudo apt-get update
  2. sudo apt-get install ubuntu-desktop

Then the machine was shutdown and the GTX 550 reinstated.

I then booted the machine with quiet splash nomodeset.

This step might be skippable, but this is the order I did it in. I downloaded the NVIDIA proprietary drivers as recommended by Matthew and installed in the same way.

I then rebooted again, and again booted with quiet splash nomodeset.

I then went to the additional drivers section and used this to install the current NVIDIA drivers and rebooted.

There ends my afternoon and evening of building and installing Ubuntu 12.04 on a newly built desktop to become my media server.


Here is what you need to do. This is from my wiki but it should work for what you are trying to accomplish.

  1. Remove Graphics Card from your machine.
  2. Install Ubuntu (You shouldn't get any errors when running generic driver.)
  3. After Ubuntu is installed then put graphics card back into machine. With tower still on! (USE EXTREME CAUTION [If hotswapping is too much then turn machine off and then install]) Above method doesn't work with GEFORCE 550Ti Graphics card. Hotswap required.
  4. Go to NviDia website and grab the linux driver it will come in .run format
  5. Install Driver using the following steps.

    5.1. Move the driver to the desktop and rename it something simple and easy to note.

    5.2. CTRL+ALT+F1

    5.3. Run sudo /etc/init.d/lightdm stop.

    5.4. Run cd ~/Desktop DRIVERNAME.run (What you renamed it.)

    5.5. Run chmod +x DRIVERNAME.run

    5.6. Run sudo ./DRIVERNAME.run

    5.7. Follow instructions and continue. TIP: If you still get hung with "It appears you are running "X" server then change the command on Step 5.3 to as follows: sudo /etc/init.d/gdm stop.

  6. CTRL+ALT+F7

  7. CTRL+ALT+T (Only use steps 7 & 8 if you can't access the restart button or see your screen.)

  8. sudo shutdown 0 -h

  9. Boot computer and enjoy :) I suggest printing these instructions.

If reboot leaves you at a terminal, try: sudo xinit gdm.

Please Note If you don't want to hotswap graphics card then shutdown the computer before installing and then turn computer back on.

By following this guide you agree to not hold askubuntu.com or any of its affiliates accountable for damages that may incur from improper procedure

  • I'm not fancying the idea of hotswapping my video card, but I have downloaded the .run file from nvidia to the console, then renamed it. But lightdm and gdm aren't in init.d to stop. I then run it as you said, but I still get the same problem on rebooting :/ – Jim Jul 24 '12 at 20:39
  • Don't fancy the idea of hotswapping either but try installing it with your graphics card removed completely. Once it is installed then put it back into machine and boot up and continue with the instructions. The Graphics Card HAS to come out. – user78723 Jul 24 '12 at 20:45
  • Now it boots to the console on the onboard video ... I have a hunch I need to install the whole X windows system as well, and the nvidia drivers don't place nice with the console for some reason. OOPS just realised I should have mentioned this is the x64 Server version I'm having issues with. I forgot to put that in the text originally. – Jim Jul 24 '12 at 21:06
  • And after apt-get install ubuntu-desktop : it appears to boot elegant on the on board graphics adapter. Now to tempt fate .... – Jim Jul 24 '12 at 21:30
  • Lol well I don't know about x64 server but hopefully I was of some assistance. – user78723 Jul 24 '12 at 21:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.