I installed Ubuntu 12.04 (from a bootable USB) alongside my Windows Vista Ultimate operating system. Everything during installation went smoothly and at the end I got the message that Ubuntu is installed and I need to restart the computer which I did. However, when the computer restarts it automatically goes to Windows Vista and there is no option to load Ubuntu. Now the only sign of Ubuntu existing on my computer is that the hard drive size is 50gb smaller (which I allocated to Ubuntu during its installation). Can anyone please guide me what to change to bring the installed Ubuntu to life?

  • Follow the 2nd option from here help.ubuntu.com/community/Boot-Repair – atenz Jul 24 '12 at 18:31
  • Grub may be installed in the USB instead of the hard drive. to confirm, please boot again with the USB plugged in. If Grub is in the USB you should see the choice to boot Ubuntu or Windows. – user68186 Jul 24 '12 at 18:31

This problem is duplicate with no grub menu for 11.10 and 12.04LTS .

  1. Boot with your USB plugged in. Enter the Ubuntu system.

  2. In the terminal, type in

    $ sudo grub-install /dev/sda 

    (if you get an error, replace sda with hda), and then

    $ sudo update-grub
  3. Reboot without the USB plugged in. You should see the grub menu now.

  • thanks a lot, it worked. However there are 2 additional options available in the grub list; one is "microsoft windows XP" which I dont have anf the other one is "dell utility partition". Is there any way to get rid of them to have a more tidy list? – Sam Jul 24 '12 at 19:30
  • The grub menu is automatically generated by detecting the operating systems installed in your machine. Sorry I don't know how to modify it. – spica Jul 24 '12 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.