I had been running Mint 12 before, and everything was working there. I switched to Ubuntu 12.04, and now I am very frustrated.

When I run ndk-build, I get

/home/buzz/ndk/prebuilt/linux-x86/bin/make: not found

So, I changed to that folder directly. When I type in ./make, I get

bash: ./make: No such file or directory

Typing ls clearly shows the file where I am! I did some hacking around (pointing to external tools) to get past each error (just to experiment), and I ran into this!

/home/buzz/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86/bin/arm-linux-androideabi-gcc: Command not found

Why? Why are all these files unable to be found? As I said above, this was all working just fine in another distro. What changed? What's extra frustrating is that if I push TAB to auto-complete, it works. So, the file is clearly there (and clearly marked with execution permissions). So, why can't it be found?

  • Did you try sudo ndk-build? – Mitch Jul 24 '12 at 15:13

I found the answer.

I installed ia32-libs, and everything started working. It's bizarre that running an executable of the wrong architecture results in "command not found". I was trying all the wrong things.


Probably would have been enough to install the i386 variant of libgcc1.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. – blade19899 Sep 27 '12 at 8:14
  • 2
    @blade19899 It is an alternate answer. Especially since there is no ia32-libs in newer versions (e.g. 12.10) anymore. – abergmeier Sep 27 '12 at 13:46
  • 2
    +1: This worked for me under Ubuntu 12.04 and you make an excellent point about ia32-libs being removed in Ubuntu 12.10. – Gili Sep 30 '12 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.