The title pretty much sums it up. I recently purchased a new laptop with a Nvidia GT 620M, in order to use CUDA. I also have an Intel integrated graphics card.

I first proceeded to install the developer drivers as I'm accustomed to, and tested the setup with a cudaGetDeviceCount - which returned 0. A quick glance at lspci also gave this:

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation Device 1140 (rev a1)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Which confirmed that linux does not detect the graphics card (while Windows does).

Overall, I attempted installing the following drivers :

  • the CUDA developer ones (295.41) and the 295.59 ones
  • either manually or using a package from a repository (namely ppa:ubuntu-x-swat/x-updates and ppa:upubuntu-com/nvidia)

I also tried reinstalling Xubuntu 11.10 aswell as the above drivers, in vain. Browsing through other related threads didn't help much either.

Would any of you kind sirs help me out of this predicament?

Thank you.


This is nvidia-optimus enabled laptop and this isn't supported in linux by nvidia.

Please see discussion over here with same problem.

The laptops with optimus won't work with nvidia drivers. It requires bumblebee to disble nvidia card and use it to some extent via virtualgl

bumblebee isn't a real solution (like when you are using the device for development). see here Can't use nvidia card/driver on optimus notebook.

If your laptop has BIOS option to disable integrated GPU and use only nvidia one then only you can fully use the device.


If the device is wired to HDMI port you can use the device in an external monitor. For external monitor setup see here → https://github.com/Bumblebee-Project/Bumblebee/wiki/Multi-monitor-setup

  • I remember coming across that post, but I guess I misinterpreted and didn't think bumblebee was mandatory for optimus-enabled cards. I'll look into it. I tried disabling the integrated GPU but: my bios has no such option, and when I attempted to do so on Windows, my screen went black. Shutting down and waiting for a minute must have reactivated it afterwards, since everything went normal. Any advice regarding that? Thank you very much. – Henry Tarded Jul 24 '12 at 9:54
  • bumblebee isn't mandatory un till you want to save power and use proprietary drivers (to some extent). If in BIOS there is no option there is no way to disable in any OS. The nvidia one isn't connected directly to laptop screen. The intel card does. So nvidia is connected to laptop screen via intel card meaning you can't disable it. Some manufacturer provide hidden BIOS option to disable optimus like (acer). Have a look. The last option would be using nvidia card via HDMI (hope that nvidia one is connected over HDMi directly). What is your laptop model? – Web-E Jul 24 '12 at 10:09
  • My laptop model is Samsung 530U4C. There's apparently no BIOS option allowing you to disable Optimus (unfortunately). The HDMI solution you suggest is meant to allow you to use the device for displaying purposes, unless I'm mistaken, and bumblebee isn't meant for development purposes.. so I guess I'm screwed! – Henry Tarded Jul 24 '12 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.