I'm fairly new to Ubuntu and am trying to learn more.

While looking for information on something unrelated, someone suggested using Ctrl+Alt+F2, when I did this it went to a terminal screen, and I couldn't figure out how to get out, so I restarted my computer.

When it loaded back up, it was in 640x480. I went to the terminal and put in xrandr -s 1280x800 (that's not my screens resolution, it's much higher but I can't remember the exact value) and it said to me Size 1280x800 is not found in available mode

I'm using a Nvidia GeForce GT 540M video card, I heard that might be a problem...
I'm stuck at 640x480 right now..so please someone help! haha Thanks in advance.

  • your laptop probably use nvidia optimus system. Please see askubuntu.com/questions/36930/… – Web-E Jul 24 '12 at 4:33
  • THIS semi-related "fix" resolved my stuck-in-640x480 problem: askubuntu.com/questions/156367/… ("apt-get remove" intel, reboot). I'm still scanning the forum seas for a definitively helpful resolution to "Nvidia Can't Do Unity 3D" situation (which lead me to a bunch of Nvidia driver fixes that not only didn't work, but they broke my display). – Keeferman Aug 26 '12 at 20:16

After switching to the virtual terminals at Control+Alt+F1 to F6 you can always switch back by pressing Control+Alt+F8.

It's very weird that your configuration changed permanently just by changing to the virtual terminal. Are you sure you didn't do anything else?

If you installed the proprietary Nvidia driver, you will probably stop using it if you move /etc/X11/xorg.conf to i.e. /etc/X11/xorg.conf.nvidia.old . Ubuntu should use autodetect and use the nouveau driver (which I guess works, since it worked in the beginning).

You could alternatively try to configure your nvidia card using nvidia-xsettings, it's a tool that comes with the driver.

You could also try inserting a ModeLine into your x.org. I'd suggest the other options first. Here's an example of a modeline that might work with your monitor:

# 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

Try reading this section first: https://wiki.archlinux.org/index.php/Xrandr#Adding_undetected_resolutions

If it works, you can add the modeline permanently like described in the next section in the link.

| improve this answer | |
  • I'm not sure...but I tested pressing 'Ctrl-Alt-F1' and pressed 'Ctrl-Alt-F8' and it didn't work, so I tried 'Ctrl-Alt-F7' which worked...How can I fix my resolution, though? – John Jul 23 '12 at 20:20
  • I told you one way to fix the resolution: stop using the nvidia driver. – Janus Troelsen Jul 23 '12 at 20:25
  • Ok...but I'm trying to use VirtualBox for Windows 7 and it's requiring me to use my NVidia, what should I do about that? – John Jul 23 '12 at 20:30
  • ok, try nvidia-xsettings or adding new resolutions as explained in the updated answer. – Janus Troelsen Jul 23 '12 at 20:31
  • Ok...so I changed xorg.conf to xorg.conf.nvidia.old and did 'sudo apt-get update' then xrandr, but it didn't do anything, did I do this wrong? – John Jul 23 '12 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.