I'm former Chromium-browser user, but after not upgrading the PPA for 2 months, I switched to Google Chrome browser yesterday. Everything is okay, except some strange behavior on some pages and crashing after loading "chrome://" configuration pages. The best known website with strange behavior is youtube, there is a picture what I see: Youtube When I open user menu in top right corner, it crashes that way and even after closing the menu, some parts of menu stay display.

You may say it's Youtube problem, no, I have this problem at least on three other websites, here it is on Imgur: enter image description here The problem isn't for the whole side, sometimes it happens from the middle of the screen.

The interesting part is that it happens everytime in the same distance from the right border. When I check the DOM elements with the Developer tool, the overlay which shows element's position is rendered how it should be. What is more, if there is anchor after the crashed area, it works after clicking on it. Selecting text in crashed page is impossible.

I hope there is enough information to give me an advice, thanks in advance. :)


Here is what the browser posted in "chrome://gpu-internals/":

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Hardware accelerated
3D CSS: Hardware accelerated
CSS Animation: Software animated.
WebGL: Hardware accelerated
WebGL multisampling: Hardware accelerated
Problems Detected
Accelerated CSS animation has been disabled at the command line.
Accelerated 2d canvas is unstable in Linux at the moment.

Ubuntu 12.04 | Gnome-shell 3.4.1 | ATI Radeon 4550 | Screen resolution 1024*768 | Chrome version 20.0.1132.57 (Official Build 145807)

  • This seems to be a rendering problem, and so may be related with video driver which is encountering problem rendering graphics-rich screens, but then, if it's not happening with other browsers or windows, then it may be a bug of Google Chrome.
    – Samik
    Jul 23, 2012 at 17:13
  • Yes, it happens only in Google chrome. There are even more pages affected, so I was forced to get back to Chromium-browser 18.* .
    – user72274
    Jul 23, 2012 at 17:23
  • Could you type 'chrome://gpu-internals' into the address bar and cut/paste the parts that say 'Graphics Feature Status' and 'Problems Detected' ? Jul 23, 2012 at 18:08
  • @MarkPaskal - I've edited my question.
    – user72274
    Jul 23, 2012 at 19:07
  • 1
    On the latest version of Chrome / Chromium (Version 41.0.2272.76 - June 2015) the address to use is now chrome://gpu
    – Eborbob
    Jun 21, 2015 at 9:48

4 Answers 4


It might be that the newer version of Chrome simply does not like your GPU. I have had issues similar to yours and have solved them by turning off the compositing and 3d acceleration features.

Type chrome://flags into the address bar and set the following items:

GPU compositing on all pages: Disabled (Three options in a drop-down.)

Disable accelerated 2D canvas: Enable (Click the link that says 'Enable', the box will turn white.)

Disable accelerated CSS animations: Enable (Like above, the item will turn white.)

Then click the button that shows up at the bottom of the page Relaunch now to restart chrome and test if this worked.

  • Doesn't work for me with a ATI HD7970 and Linux Mint + Mate.
    – Leandros
    Oct 10, 2012 at 18:29
  • Try Jove' answer below and see if that works for you. The DE shouldn't make any difference. Oct 11, 2012 at 19:27
  • Nope, strange behaviour as always on Youtube, only on Youtube, I guess other sites were fixed through your solution.
    – Leandros
    Oct 11, 2012 at 19:31
  • The only option I had available of the three was Disable accelerated 2D canvas - enabling this seems to have cleared up the random white blocks that were appearing over pages in Chrome.
    – Eborbob
    Jun 21, 2015 at 9:50
  • 1
    Incidentally, it is rather confusing but you need to enable the disable options to disable a function...
    – Eborbob
    Jun 21, 2015 at 9:52

I had the same problem, and I learned this command from Google:

google-chrome  --blacklist-accelerated-compositing

I had the problem myself with some versions of the Intel GM965/GL960 driver. I suggest that you try updating your video drivers. You didn't mention if are using fglrx or not.

  • They're using the official drivers, chrome blacklists the open source radeon driver and you can see from the chrome://gpu-internals that WebGL is hardware accelerated. Jul 24, 2012 at 4:25

I have Ubuntu running in Virtualbox and at times Chrome's rendering issues would cause Ubuntu's rendering to crash forcing me to reboot the VM. My solution is as the same as Jove's above but I've added an alias to my ~/.bashrc file that helps me start chrome quickly via a terminal:

alias chrome="google-chrome --blacklist-accelerated-compositing &"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.