I'm trying to install ffmpeg on my dedicated server running on ubuntu 10.04. I want to convert flv-videos to mp3 sound files. As I found out, I have to install libavcodec-extra-52. When I use

sudo apt-get install libavcodec-extra-52

it says that I don't have libfaac0 (>= 1.26) and libmp3lame0 and that they aren't installable. Using

sudo apt-get install libmp3lame0

it says that the package isn't available at any source. Do I need some special repository to be able to download those codecs? Right at the moment, I have only three sources for packages in /etc/apt/sources.list which are predefined and hosted by my provider.

Thanks in advance.

  • sudo apt-get update && apt-cache search libavcodec-extra what is the result of this command? Also try this combo to try to fix some apt issues sudo apt-get update --fix-missing && sudo apt-get upgrade -y && sudo apt-get install -f – user827992 Jul 23 '12 at 16:08
  • The first command gives a list of several repositories and "OK" in front of each. Then it says winff - graphical video and audio batch converter using ffmpeg libavcodec-extra-52 - ffmpeg codec library. The second command repaired many packages, but didn't change anything. – Michael Jul 23 '12 at 16:22
  • 10.04 is EOL and off-topic. – RobotHumans Jan 31 '14 at 2:03

Follow this guide and you should be fine.

Ubuntu, or in better terms, the package libavcodec-extra-52, does not support the libraries that you must have installed in order to use ffmpeg for what you want to do. You can find explanations and howtos at that linked guide.

  • Thanks, I already found that link before and tried solution B. That's where I found out that I need libavcodec-extra-52. I just tried solution A and successfully compiled LAME and ffmpeg. BUT I still don't have libmp3lame, so I can't rip a mp3-file from a flv-file because I don't have the codec. How can I build a libmp3lame out of the already installed LAME? – Michael Jul 23 '12 at 17:21
  • I just noticed that there is a folder libmp3lame in the LAME sources folder. But there is no configure-file and make doens't do anything. – Michael Jul 23 '12 at 17:31
  • did you have libmp3lame0 installed? sudo apt-get install libmp3lame0 if you have to find a package use apt-cache search package, if you are looking for what libraries are missing for a specific executable, just use ldd $(which ffmpeg) – user827992 Jul 23 '12 at 17:34
  • Okay, the problem is solved, i forgot to use --enable-libmp3lame while configuring ffmpeg. Now everything works fine. – Michael Jul 23 '12 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.