I Install Ubuntu 12.04, After that I followed all the guides and Forums to use my Reliance Netconnect+ which has Modem ZTE AC2737. It does not connect and shows

You are now offline after trying for connection

I called Reliance Tech Support but they said this model is not supported

  • post result of lsusb after plugging the device
    – Web-E
    Jul 23, 2012 at 15:27

2 Answers 2


I also faced the same issue, but somehow it worked for me after some tweaking.

Solution 1: (If you have access to Windows Machine)

Just go to the Reliance Netconnect Plus UI in Windows machine and in Settings change the 'Mode' to 'Hybrid'.

enter image description here

By doing this I found that the Reliance Netconnect Plus is recognized by Ubuntu quickly and

Now log in back to Ubuntu and connect to the internet through 'Network Manager'.

Using this method you will be registered on CDMA home network and can access the internet quickly.

The main disadvantage of this method is that we are running it under 'Hybrid' mode, which means that the internet may switch to 'CDMA 1x' mode and the internet speed will go down.

For me this happens only for 5-10 minutes then I'm again switched to fast Netconnect+ mode.

To overcome this disadvantage you may use Solution 2.

Solution 2: (Using WVDIAL)

If the Reliance Netconnect Plus modem works in Solution 1 then after connecting to internet, install WVDIAL


If you have access to GSM mobile(or GSM Modem) with cheap GPRS plan, then connect your mobile to Ubuntu through Network Manager and install WVDIAL. I have never experienced any difficulty with GSM Modem when connecting to Internet through Network Manager.

(i) Open Terminal (Keyboard Shortcut: Ctrl + Alt + T ) and type

sudo apt-get install wvdial

(ii) Open up wvdial’s configuration file using this command

gedit /etc/wvdial.conf

(iii) Paste the below code into the window that pops up ( make sure to enter your relevant details )

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = USB Modem
ISDN = 0
Phone = #777
New PPPD = yes
Modem = /dev/ttyUSB0 (This may also be dev/ttyUSB2 depending on where you plugged in your device)
Username = 9xxxxxxxxxx (your username, should be a number )
Password = 9xxxxxxxxxx (Your password , should be the same number)
CBaud = 460800

Delete all the comments in the brackets . The fields you should edit are Modem , Username and password the only ones with comment . Save and exist .

(iv) Thats it. Remove the GSM mobile(or GSM Modem) from PC/laptop and plug in Reliance Netconnect+ Modem. Wait till it gets recognized by Ubuntu, run lsusb command to know if it detected as modem and then

Run wvdial using following command

sudo wvdial

Internet using wvdial works out of box. Now you can change the Network Mode to 'Netconnect+' by using Reliance Netaconnect Plus UI in windows and log back to Ubuntu to use the uninterrupted broadband using wvdial.

  • worked like magic. Please tell how to know if my port is ttyusb0 or something else
    – bubble
    Jul 17, 2013 at 11:24

Log in to your Ubuntu system and insert the dongle. You may hear some kind of sound after detection of the dongle in the system.

Now at the top right corner you may see the small network connection icon.

Click that icon and you will see a menu. Click the “Edit Connection” option at the bottom of this drop down menu and it will take you the Network Management window.

Click the “Mobile Broadband” tab and then click Add. This will take you to the Dial-Up Connection Setup Wizard. Just follow the wizard and it will take hardly a minute. Your Device will be detected automatically, click on Continue.

  • use *777# for Dial up number for EVDO
    – BigSack
    Aug 10, 2012 at 10:10
  • well i know that simple method. but it does not work for this modem that is the reason why i posted here, it just shows you been disconnected from network after trying to connect to internet
    – Yogesh
    Aug 17, 2012 at 16:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.