I am on a Sony VIAO E-series, it is Brand new, so I am still setting things up, and learning to use Ubuntu for the first time. I am dual booting Win7 and Ubuntu 12.04, but I indend to mostly use Ubuntu.

Problem is, I have not been able to get Bluetooth to recognize any devices that I try to connect, most important of which is my bluetooth mouse. It always searches, but will not find my mouse nor any other bluetooth device around. The thing is, the bluetooth connected to my mouse just fine when I first installed 12.04 as 32bit. I have since realised i had a 64bit computer, and so I reinstalled and put on 64 bit. However if I recall right the bluetooth first stopped working after the first time I restarted my computer back in the 32 bit version. Bluetooth works flawlessly when I am running windows 7.

I have been looking for drivers, but have not found any, I have also tried to blueman in place of the default bluetooth program... also no luck.

The trackpad on this computer is awful. Getting the mouse working is very important. Half the time the trackpad inexplicbly throws the mouse to the left edge of the screen and starts an application that I dont want to use.

Possibly useful info from the terminal:

$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 006: ID 0489:e036 Foxconn / Hon Hai Bus 001 Device 004: ID 5986:02d3
Acer, Inc
  • Did you try to remove the device and re-pair again? – Takkat Jul 23 '12 at 6:30
  • not sure what you mean remove the device. The computer wont even find it in the first place when searching for devices. It connected a while back when I was using 32 bit, but since I re-installed into 64, anything saved on the computer such as device info is gone. – Brian Jul 23 '12 at 7:06
  • There is an issue with simple secure pairing. Does the Bluetooth Settings (from the panel) list the device? – Takkat Jul 23 '12 at 7:51

this problem is related to kernel , whenever a kernel upgrade happens, the status of working or non working bluetooth toggles with it, ha.ha..ha

  • it was not working in was working in .24, .25, .26 and not working in .27 .(atleast on my system) – techvish81 Jul 27 '12 at 9:14

First off you need to go back to 32 bit 12.04 and the issue will likely be resolved. There is a reason on Ubuntu's website for downloading that it has 12.04 x86 (RECOMMENDED). Just because you have a x64 machine doesn't mean you need to use x64. x64 Simply means that you can run x86(x32) or x64 bit programs. You won't run into any issues with x64 bit programs on Ubuntu unless you are running Wine but even then wine will resolve your issues. I highly Recommend going back to x32 as it is recommended and if it worked before then it is definitely your best bet.


I currently have a x64 bit machine dual booted with Windows 7 Ultimate (x64) and I run all my games and everything that I want to do on Ubuntu in a x32 bit environment without issues. There isn't a need for a x64 bit environment unless you are developing. That being said after you have read this then you have learned the most important part of OS is this x64 can run x64 or x32. Therefore if you put x32 12.04 on your system you won't have any problems as your system was designed to run either or.

BTW x32 bit is lighter on the system and runs better than x64 and with no issues from using x32 then why not use the valuable resources and enjoy the extra speed.

Very Respectfully Matthew Kaulfers

  • Do you have a reference for the assumption that there are no Bluetooth issues in 32-bit Ubuntu? – Takkat Jul 23 '12 at 10:54
  • You stated it. So my reference was to what you said. I was simply educating on not needing x64 bit so why use something that is going to slow you down in the long run and complicate what should be easy. – xTwisteDx Jul 23 '12 at 12:07
  • That would be another topic then ;) – Takkat Jul 23 '12 at 12:17
  • Well as I said, I STARTED having the problem even when I had the 32 bit (That time the device had disconnected, and refused to reconnect). Also because of the time involved and having to backup/reinstall everything... I'd rather not do that -again-. That said... I will consider going back to 32 to be a last resort... since I am not 100% sure if it will fix my problem, and It would be frustrating to say the least to reinstall the OS twice. I find it unusual that the 64bit should be the cause of my bluetooth not working properly... Any other ideas? – Brian Jul 23 '12 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.