Possible Duplicate:
What should I do when Ubuntu freezes?

Ubuntu 12.04 LTS system freezes completely, only way out is a hard reboot :(

It's random, often while doing Shotwell, sometime Google Earth, few times even while ejecting a SD drive! I also had a few random warnings that Compiz crashed (maybe related ?!).

Here are my specs:

  • Brand new Desktop from System76
  • Ubuntu 12.04 LTS 64 bit
  • Kernel: 3.2.0-26-generic
  • 3rd Generation Intel Core i5 3570K ( 3.40GHz - 6MB cache - 4 Cores - HD Graphics 4000 )
  • 8 GB DDR3 - 1600 MHz
  • 2 TB HDD
  • 5
    Would be helpful see your dmesg. When you get a freeze, reboot, open a terminal (Ctrl+Alt+T), type gedit /var/log/dmesg.0, select all the text, copy it, go to paste.ubuntu.com, paste it and post here the address. – Eric Carvalho Jul 22 '12 at 0:01
  • Have you run a memtest, and how much swap do you have? – nanofarad Aug 2 '12 at 15:54
  • Random crashes like that are often to do with Hardware or Drivers. (For me graphics card drivers are a usual suspect). Perhaps it's worth asking System76 Support? system76.com/support – Jason O'Neil Aug 6 '12 at 2:11

It's just a hunch, but perhaps the problem originates from using the 64-bit version of Ubuntu.

I had a similar problem a while ago with an Ubuntu 9.04 Jaunty 64-bit install (it was a fresh installation, no upgrade, no beta, nothing special at all): Every few hours the computer randomly crashed, even if the system was hardly consuming any resources, forcing me to reboot the computer by pressing the reset button. I often found myself simply moving the mouse across the screen when suddenly everything froze.

I asked for help in an Ubuntu forum, posted syslogs, ran a memtest, checked the electrolytic capacitors inside the computer, to no avail. I assumed some part of the hardware to be defective, but did not really know how to go on from there.

Eventually, when support for Jaunty ran out, I wanted to move to Lucid. A friend of mine, whose Jaunty 32-bit system ran smoothly and who I had told about my trouble, suggested to go for the 32-bit version because he had a hunch that it was the 64-bit version that had caused me all this pain.

And what can I say? I have been running Lucid 32-bit for two years without a single crash, on the exact same hardware that Jaunty 64-bit had been on.

I never learned whether the problem did arise from the use of 64-bit, so I'm really just guessing here, but it might be worth giving it a try (even though it might be a bit frustrating to be sitting on 8 GB RAM and being able to use only 2 to 3).

These are my specs, by the way:

  • Intel Core 2 Duo 3.16 GHz
  • 4 GB RAM
  • ATI Radeon HD 4850
  • 500 GB HDD

Have you tried switching to console when it happens (ATL+CTRL+F1)?

I somteimes had issues like that when using a special version of XBMC, the system each time seemed to freeze completely, but then I found out switching to terminal worked. Then I could do a login on the console and use top, ps, and kill commands to investigate and kill XBMC. You then can get back to your desktop by pressing ALT+F7.


PS: And when on console, try dmseg as suggested by Anju.

  • ... I'm on 64-bit too and I won't go back ;-) – Axel Aug 16 '12 at 19:04

I had a similar issue on a brand new machine (xeon cpu) with 12.04 amd64. Nothing in the logs.
Luckily there was a BIOS update avaiable, and after I applied it no crash any more.
So I would say check if there is a BIOS updated available for your system.

ps: you can easily check your hardware with
sudo lshw -html > hardware.html

Then open hardware.html with your favourite browser :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.