I have a new HP Sleekbook 6z with AMD A10-4655M APU. I tried installing Ubuntu with wubi--the first attempt ended up with a 'AMD unsupported hardware' watermark that I wasn't able to remove (the appeared when I tried to update the drivers as Ubuntu suggested)

On the second attempted install Ubuntu installed (I stayed away from the suggested drivers) but the performance was extremely poor----as in Windows Vista poor. I am not sure what the solution is--if I need to wait until there is a kernel update with Ubuntu or if there are other solutions--I realise this is a new APU for the market.

I would love to have Ubuntu 12.04 up and running--Windows 7 does very well with this new processor so Ubuntu should, well, be lightening speed.

The trial on the Sleekbook with Ubuntu 12.10 Alpha 2 release was a complete failure. I created a bootable USB. By using either the 'Try Ubuntu' or 'Install Ubuntu' options resulted in the usual purple Ubuntu splash screen, followed by nothing...as in a black screen without any hint of life. Interestingly one can hear the Ubuntu intro sound.

In case you are wondering, this same USB was trialed subsequently on another computer with and Intel Atom Processor. Worked flawlessly.

Lastly the second trial on the Sleekbook resulted in the same results as the first paragraph.

Perhaps 12.10 Beta will overcome this issue, or the finalised 12.10 release in October. I don't have the expertise to know what the cause of the behaviour is-the issue could be something else entirely. Sadly, the Windows 7 performance is very good with this processor-very similar and in some instances better to the 2nd generation Intel i5 based computer I use at my workplace. Whatever the cause is for the performance with Ubuntu 12.04 or 12.10 Alpha 2, the situation doesn't bode well for Ubuntu.

Ubuntu aside, the HP Sleekbook is a good performer for the price. I am certain once the Ubuntu issue is worked on and solutions arise, the Ubuntu performance will probably be better than ever.


Install the proprietary Catalyst drivers AMD website. (Ensure you chose Linux as the OS.) This will solve all display problems.

You can also install them from System - Additional Drivers. Your display chip will be detected and Ubuntu will let you download and install it.

UPDATE (05-Nov-2012): I got a new laptop with an APU and I ran into the same problems. Here is how you can fix the problems.

  1. Download the latest 12.10 driver from AMD website.
  2. Install the driver following the instructions given at the unofficial wiki at http://wiki.cchtml.com/index.php/Ubuntu

If you have a 64-bit system, you will need to install ia32 libs.

If the installation failed or did not work, then restart the computer with the failsafe version of the kernel at the Grub2 bootscreen menu. Press e to edit the failsafe option and then replace "ro single" with "rw xforcevesa"

Press Ctrl+Alt+F2 to go to a TTY screen. Kill the desktop with

sudo service gdm stop


sudo service lightdm stop

Run the AMD driver with sudo sh

Choose the second option of building the distribution-specific installer. (This will save you the trouble of uninstalling failed drivers.)

If the fglrx*.deb got created, install them as specified in the wiki.

Before you restart, run this command

sudo /usr/bin/aticonfig --initial

Run the command sudo reboot to restart the computer.


My a10-4600m notebook works with the 12.10 beta 1 only if you press Shift while booting to load the Grub menu and then when when the boot with so and so kernel or safe mode and other options, press the e key and then where it says quiet boot erase that and enter nomodeset instead.

That will give you a ugly boot screen but at least the screen wont cut out after the purple bit. After that you can enjoy the broken version of Unity, hopefully they will have that fixed by the time you install it.

I think the boot to black screen thing is a kernel thing because OpenSuse 12.8 Chakra 12.9 or anything with a kernel version from 3.4~3.5 wont boot without nomodeset. Maybe it will be fixed in a future kernel release.


Support for AMD Trinity is built into Linux kernels 3.4 and above; Ubuntu 12.04 doesn't have it. You might want to try Ubuntu 12.10 Alpha 2. It includes the 3.5.0-2.2 Ubuntu kernel, which is based on the 3.5-rc4 upstream Linux kernel. (Alpha 3 will be released on Aug. 2; Beta 1 on Sept. 6).

If you do try this, please post here and let us know how well it works. (I'm considering buying a laptop with the A10-4655M -- maybe the Sleekbook, or maybe a Samsung Series 5 535.) Thank you.

protected by Community Nov 29 '12 at 11:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.