135

Just created a new virtual Ubuntu server and I'm in the process of hardening it for production use. I currently have a root account. I want to do the following:

  • Create a new user (let's call them jim for the rest of this). I want them to have a /home/ directory.
  • Give jim SSH access.
  • Allow jim to su to root but not perform sudo operations.
  • Turn off root SSH access.
  • Move SSHd off to a non-standard port to help stop brute-attacks.

My problem lies with the first two items. I've already found useradd but for some reason, I can't log in as a user created with it over SSH. Do I need to beat SSHd to allow this?

10
  • Hi! I can help you in servers, I don't know what is your problem with SSH, because for me with default config never refuses my connection. You may see man 5 nologin, this writes, that if /etc/nologin exists, you can log in with root only. Try login normally, then write the results.
    – antivirtel
    Dec 8, 2010 at 16:22
  • What's the user's shell? Is it /bin/bash? Check that out in /etc/password. Make sure it's not /dev/null or /bin/false.
    – LFC_fan
    Dec 8, 2010 at 16:24
  • Yes LFC_fan, or /etc/nologin too. Use (sudo) cat /etc/passwd | grep jim
    – antivirtel
    Dec 8, 2010 at 16:31
  • 1
    @B. Roland I do have a /etc/nologin file but it's empty. I deleted it and restarted ssh but it's still just responding Permission denied, please try again. when I try and log in.
    – Oli
    Dec 8, 2010 at 16:42
  • @LFC_fan it's /bin/bash
    – Oli
    Dec 8, 2010 at 16:42

9 Answers 9

128

SSH is very picky about the directory and file permissions. Make sure that:

  1. The directory /home/username/.ssh has permission "700" and is owned by the user (not root!)
  2. The /home/username/ssh/authorized_keys has permission "600" and is owned by the user

Copy your public key into the authorized_keys file.

sudo chown -R username:username /home/username/.ssh
sudo chmod 0700 /home/username/.ssh
sudo chmod 0600 /home/username/.ssh/authorized_keys

There is NO need to add the user to /etc/ssh/ssh_config.

7
  • 3
    My problem was chown, I created ~./ssh as root and never gave the user ownership.
    – Gerve
    Apr 9, 2014 at 18:05
  • 1
    My problem was that I was trying to use /root/.ssh/authorized_keys instead of /home/bob/.ssh/authorized_keys.
    – Alex W
    Apr 28, 2015 at 15:57
  • I can confirm: on our VPS hosting there was no need to edit ssh_config. Setting up that directory and file was enough.
    – superjos
    May 6, 2015 at 9:46
  • 2
    For me it had to be chmod 755 /home/username/.ssh otherwise it wouldn't work. Dec 2, 2016 at 22:58
  • 1
    Much easier to login as user (or sudo su --login {user}) and run ssh-keygen -> The ".ssh" folder, key+cert and permissions are completed. Just create authorized_keys as per your instructions.
    – B. Shea
    Oct 10, 2017 at 16:55
108

Edit (as root) /etc/ssh/sshd_config. Append the following to it:

Port 1234
PermitRootLogin no
AllowUsers jim

Port 1234 causes SSH to listen on port 1234. You can use any unused port from 1 to 65535. It's recommended to choose a privileged port (port 1-1024) which can only be used by root. If your SSH daemon stops working for some reason, a rogue application can't intercept the connection.

PermitRootLogin disallows direct root login.

AllowUsers jim allows user jim to login through SSH. If you do not have to login from everywhere, you can make this more secure by restricting jim to an IP address (replace 1.2.3.4 with your actual IP address):

AllowUsers jim@1.2.3.4

Changes to the configuration file /etc/ssh/sshd_config are not immediately applied, to reload the configuration, run:

sudo service ssh reload
11
  • 10
    +1: Note: these instructions are still applicable to newer versions of Ubuntu (e.g. 13.04). If you do want root login, however, (perhaps you're still setting up the server), you must set PermitRootLogin to yes and also add root to AllowUsers. Oct 15, 2013 at 18:57
  • 4
    what's the password for this user? Jan 29, 2016 at 3:45
  • 1
    @Lekensteyn I've found just adding a new user to Ubuntu itself creates an ssh account for that user.... useradd -m -G sudo,adm -s /bin/bash mecharok and passwd mecharok Jan 30, 2016 at 18:00
  • 3
    @Wolfpack'08 Use AllowUsers username1,username2 to restrict SSH logins to those users. Ensure that sshd is reloaded. If this does not help, please create a new question.
    – Lekensteyn
    Jan 30, 2016 at 18:16
  • 2
    @Lekensteyn your command: AllowUsers username1,username2 has the wrong format and will lock you out of your server!! The correct command to set is: AllowUsers username1 username2
    – kolaworld
    Apr 4, 2020 at 19:08
13

There will be clues in /var/log/auth.log for why SSH (or PAM) is rejecting the login attempt. Additional clues may be found by using the -v option with the ssh client. Several common situations, some mentioned in the other answers:

  • the user account lacks a password, or is otherwise disabled (see man passwd, try resetting the password or checking the contents of /etc/shadow).
  • /etc/ssh/sshd_config is configured to disallow the login (DenyUsers, AllowUsers, PasswordAuthentication, PubkeyAuthentication, UsePAM etc, see man sshd_config).
  • the user's shell is not listed in /etc/shells.
  • various permission problems on directories or files related to SSH operation: /etc/ssh, /home/jim/.ssh, /home/jim/.ssh/*, etc.

I'd also recommend using adduser (instead of useradd) for adding new users; it is a little more friendly about various default account settings.

As long as the user is not part of the admin group, they will not be able to sudo to root. For them to use su, you will need to set a root password (passwd root), after which I recommend setting PermitRootLogin=no in /etc/ssh/sshd_config.

1
  • Thanks a lot for great answer- specially "adduser" helped a lot! Aug 21, 2013 at 11:47
11

I could be wrong but I always have to install the server daemon before I can connect (At least on desktop) ssh is installed by default but that is just the client

this command installs the server

sudo apt-get install openssh-server

You can change the port and stop root login by editing

/etc/ssh/sshd_config

This requires you to restart the service though.

sudo service ssh restart

1
  • This is a virtual server (VPS) so SSH is installed by default. It's my only interface to the server. And you can reload configuration via sudo /etc/init.d/ssh reload instead, but good information nonetheless.
    – Oli
    Dec 8, 2010 at 16:54
10

Jim will not have SSH access until you have set a password. As root execute:

grep -i "jim" /etc/shadow | awk -F':' '{ print $2 }'

If this command returns a "!" character then login is disabled for this account. Executing passwd jim as root will prompt you for a new and confirmed password string after which the grep command above should return a hashed string representing the password for jim.

Also be sure to verify that jim has a login shell, set by default, and a home directory that exists.

Please note lekensteyn's post for information on modifying SSH server settings.

1
  • "If this command returns a "!" character then login is disabled for this account" Note this doesn’t mean you can’t SSH; only that you can’t do it with a password (vs. with your public key).
    – bfontaine
    Apr 4, 2017 at 14:13
5

In my case I had a group which was allowed access and the user was not part of it. This solved it for me.

Using the example above with the user jim and assume member of group jim as it's only group (issue groups command while logged in as jim to find groups you are a part of). In my /etc/ssh/sshd_config file I had AllowGroups sshusers entry and thus needed to add jim to the sshusers group. Below is how this would be accomplished:

usermod -a -G sshusers jim

Replace your group and user as appropriate for your configuration.

1
  • 1
    you should improve your answer by referencing to a source that better explains your example or by adding relevant information basing your example on OP's original question. for example, the user specified jim as a dummy user to help provide context. the article here explains it well.
    – user383919
    Feb 13, 2018 at 0:29
0

There might be some instances that the PasswordAuthentication is disabled by default.

Kindly check /etc/ssh/sshd_config and ensure that the PasswordAuthentication attribute is set to yes.

0

@Lekensteyn I'm unable to leave a comment to the question answer because I don't have the reputation - but I tried appending

AllowUsers existingUser,newUser

to my /etc/ssh/sshd_config file and now I can no longer ssh with both my existingUser or the newUser.

1
  • I understand your pain :D I had the same issue once. Solution: AllowUsers existingUser@* newUser@* Dec 12, 2018 at 16:17
0

Simple note:

The public key should be written inside this file:

/home/newUsername/.ssh/authorized_keys

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.