Can someone help me out and explain or point me in the right direction on how to check video drivers and see if my video card running okay?

I had 10.04 installed on my Thinkpad r61 with Compiz Manager and life was great, until the machine took water damage. I bought an ASUS (X54H) since and am trying out 12.04, but the desktop just doesn't look right.

I always struggled with video driver installation. There are no proprietary drivers available in the hardware manager.

When I run lspci | grep VGA:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

I will greatly appreciate your help. I want to use Linux more, but like I said video drivers appear to be my biggest concern. I have also tried 12.04 on my desktop PC, but again failed to configure video card, so switched back to Windows 7.

The Intel graphics driver is part of the xserver-xorg-video-intel driver package, which is installed on all Ubuntu systems by default. And since it isn't a proprietary driver package, it doesn't show up in jockey (aka the Hardware Drivers application).

Just to ensure it didn't get removed by mistake (very slim possibility), just run this command:

sudo apt-get install xserver-xorg-video-intel

If the driver is installed, and you're still having issues with graphics on your desktop, then please file a bug report against the xorg package, using this terminal command:

apport-bug xorg
  • You just saved my day! Thanks! – Bálint Pap Sep 18 '16 at 17:31

Install mesa-utils, that might work.

sudo apt-get install mesa-utils  

it worked in my case.read this question posted by me

before installing mesa-utils enter image description here

after installing mesa-utils enter image description here

mesa-utils is just not there in ubuntu 12.10.doesn't really matter.

  • 1
    This worked for me on Ubuntu 12.04 Dell Vostro 2420 – chhantyal Jun 25 '14 at 11:29
  • Me too, Ubuntu 12.04 Dell Latitude D630 – chuyenvien94 Feb 25 '16 at 4:26
  • Where did you take this Details window? – Dims Aug 12 '17 at 19:28
  • @Dims Sorry but this is almost 4 years old, and I no longer use Ubuntu, so I don't remember. – Registered User Aug 18 '17 at 13:19

The Ubuntu Forums has a good description of how to install/update the Intel graphic driver in Ubuntu.

Extract of the pertinent part is as given below:

  1. Open a terminal session by pressing CTRL+ALT+T

  2. Run command to install ppa:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    
  3. Install the drivers for your graphics chip

    sudo apt-get install xserver-xorg-video-intel
    

Ubuntu no longer uses xorg.config file. You will have to create this file in the next step and enter in values.

Create file sudo -H gedit /etc/X11/xorg.conf and edit it

Section "Device"
Identifier "Card0"
Driver "intel"
Option "AccelMethod" "sna"
EndSection

Save and close it. Restart your interface or just reboot you machine and go back to system settings - details - graphics and verify that your drivers are displayed.

With Ubuntu 12.04 LTS and Intel graphic processor I suggest the following

sudo apt-get install xserver-xorg-lts-precise

Some issues with Intel Graphic Processors and suggested remedies can be found here.

I hope this helps someone, I actually was trying to load the MAME arcade emulator on my Lubuntu 15.10 and had to do the following since I got this error:

intel_do_flush_locked failed: Input/output error

I tried every suggestion in this thread, which didn't seem to resolve the issue. I also did the following:

tried the steps here: So, the rub (if your Google-fu takes you here directly) to get this to work (on Ubuntu 12.04 and 12.10):

# add-apt-repository ppa:ubuntu-x-swat/x-updates
# add-apt-repository ppa:oibaf/graphics-drivers
# apt-get update && apt-get dist-upgrade
# sed -i -e 's/"quiet splash"/"quiet splash i915.i915_enable_rc6=0"/g' /etc/default/grub
# update-grub

ALSO AFTER DOING THAT, I DID THIS:

Lubuntu System Menu [Bottom Left Corner] > Preferences > Additional Drivers Choose > Using Processor Microcode from Intel CPUs from intel-microcode [Proprietary]

INSTALLED THE OPTION ABOVE and NOW MY ERROR is gone!! I'm using a Dell Dimension 3000 which this worked/resolved issue.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.