5

I am used to open a folder from the keyboard with a shortcut. The alternatives are:

  • Use Unity Dash with the shortcut SUPER + F to open the Dash File Lens
  • Open Kupfer with the configured shortcut (CTRL + ALT + SPACE, in my case)

Then I type the name of the folder and press ENTER if it is selected.
However, the window that opens up is not active but in the background. I have to press ALT + TAB to bring it into foreground.
I use Ubuntu Precise (12.04.).

Question: How can I configure Ubuntu, Unity, Nautilus so newly opened windows become foreground immediately?


Edit: This behavior only happens when another application is already open such as GEdit. It does not happen when the only other selectable entity is the Desktop.

3
  • have you tried super+1 which is my Home folder alignment no. in unity launcher panel , or try pressing super to get the icon number and try the command.
    – atenz
    Jul 20 '12 at 13:01
  • Since I use many different folders at different times having a shortcut for each in the panel is not an option. Nevertheless, I tried your suggestion and place my HOME folder there. The behavior is the same.
    – JJD
    Jul 23 '12 at 20:19
  • 1
    In Ubuntu 14.04 (with unity): Focus prevention level OFF fixed it for me.
    – user280122
    May 10 '14 at 12:18
4

This is NOT the default behaviour.Check the settings of Focus and Raise Behaviour in CompizConfig Settings Manager > General > General Options.(You may need to install ccsm first).
ccsm

1
  • I can no longer reproduce the behavior. It might have been fixed in one of the kernel releases. Nevertheless I like to grant you the answer flag. Thank you.
    – JJD
    Oct 8 '12 at 21:42
2

For me the problem is NOT solved by checking Auto-Raise, rather, by changing Focus Prevention Level from Low to Off in ccsm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.