10

I would like to stop Ubuntu from mounting my other (Windows) partitions automatically since I do not need it very often, I would like not to automount "System reserved" partition for Windows.

There is a similar question here:

How can I stop Ubuntu 12.04 from mounting Fedora 16's Swap Partition?

However, I do not have these partitions added in /etc/fstab.

How can I do it ?

For proof, my /etc/fstab:

proc            /proc           proc    nodev,noexec,nosuid          0   0
# / was on /dev/sda7 during installation
UUID=1384cee0-6a71-4b83-b0d3-1338db925168 / ext4  errors=remount-ro  0   1
# swap was on /dev/sda6 during installation
UUID=e3729117-b936-4c1d-9883-aee73dab6729 none swap    sw            0   0
#------ MY WINDOWS D DRIVE---------- I WANT TO KEEP IT
UUID=98E8B14DE8B12A80   /media/d ntfs   defaults,errors=remount-ro   0   0
17

The solution is to add them to /etc/fstab, but with options to prevent them from being automatically mounted. The option you want is noauto rather than auto. For example, to prevent a windows partition from being mounted, you could add an entry like the following:

UUID=C2A281E4A281DCF3 /media ntfs-3g defaults,noauto 0 0

You can run blkid to retrieve the partition UUID:

sudo blkid

See "Using UUID" in the Ubuntu Docs.

Or, to make it more self-documenting and simpler, although not quite as fail-proof, I have switched to using disk labels rather than UUIDs. You just need to make sure the label is descriptive and unique; unlike using UUIDs, labels are not guaranteed to be unique, but I've never run into a problem, and it's more convenient, as you can swap a different partition by using the same label, and no need to modify /etc/fstab, or to run blkid.

Contrast the above entry with this one:

LABEL=Win_sys   /media     ntfs-3g   defaults,noauto   0  0

A good explanation of fstab options can be found on the ArchWiki and on the Ubuntu Docs.

1
  • This won't mount automatically. What about the case I have an HD (Volume) with 2 partitions (NTFS). When I double click this volume on File Manager it mounts both partitions. How can I edit in fstab to not mount specific partition out of the 2? Maybe by nouser? – Royi Apr 19 '20 at 18:49
8

Just use gnome-disks facility in Ubuntu. Type this in your terminal:-

user@user-X550LD:~$ gnome-disks

Easy to use. Click on any partition and select the "settings" cog wheel down at the bottom near the "play" and "minus" signs. Select mount options and voila.

enter image description here

1
  • This one has the facility of also remove from devices list with ease. Using noauto at fstab will just not mount untill you do, but removing from system list will avoid you to mount by mistake from any kind of file manager, as far as i understand. – m3nda Aug 20 '19 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.