After creating a vhd and going through that process i'm unable to install win7 x64. I've went through various settings and trying to get it right. It'll boot the windows install but then indicate the following error (image included too):

A required cd/dvd drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.

Note if the windows installation media is in the CD/DVD drive, you can safely remove it for this step.

enter image description here

I've also set up my storage tree like so:

enter image description here

Would anyone know what the issue could be? It's asking for cd/dvd device drivers and i'm unable to install.

  • You probably have a scratched Windows CD or a broken CD drive. That message pops up when also when the setup cannot read a file from the CD you are using. – Bruno Pereira Jul 19 '12 at 19:19
  • Are you installing fro CD, or an ISO? – Mitch Jul 19 '12 at 19:21
  • From CD. I was able to install from cd before too on different machines this is the first time i've had this issue. – chrisjlee Jul 19 '12 at 19:27
  • as I can not answer on this topic (due to too less rep points): For me it turned out that my downloaded ISO (from dreamspark) was currupted! A fresh new download solved all my problems – Langusten Gustel Mar 5 '14 at 15:02
  • Seems like corruption was the culprit for me too. I tried another disk and it worked fine. – trusktr Jun 11 '14 at 20:11

I ran into this problem today, you probably already solved your problem, but I'm just adding my experience as it may help somebody else.

(I used a physical install CD and not an ISO file)

  1. Open your VM settings
  2. Go to Storage
  3. Select the CD-ROM drive
  4. Check Passthrough
  5. Boot the VM with the Windows

This solved it for me, so it might be worth a shot.

| improve this answer | |
  • 3
    I don't see any such option. Using VirtualBox 4.3.10 on ubuntu – Jonathan Apr 24 '14 at 20:36
  • That's odd I'm using VB 4.3.10 on ubuntu trusty and I can see the checkbox. It fixed the problem for me as well. – Tom Jun 11 '14 at 16:35
  • Do I have to burn the ISO to a physical DVD to be able to install the virtual machine? – Calmarius Nov 14 '14 at 13:09
  • Step 4 solved the problem, thx :-) – leaf May 21 '15 at 7:12
  • had to shut down the VM to see the setting. The setting while it was running wasn't enabled. – tourdownunder Sep 22 '15 at 8:45

You can set a passthrough but this is also where you can point to an ISO file of your disc. I used an ISO because it makes the OS install much much faster and passthrough gets a lot of hiccups for long read times. Think of it as playing hot potato with 3 people instead of just 2.

| improve this answer | |

This is just a wild guess.

It can be complaining because some of the virtualiced hardware is not compatible out-of-the-box with Windows 7. The most likely problem is the network card, if it was another componente Windows will just connect to internet to try to download the driver.

Can you try to change your emulated NIC model in the Network section of the Virtual Machine configuration?

| improve this answer | |

This problem can also occur if your ISO or DVD is corrupted. At the company I attempted to download a Windows form the MSDN subscriptions download center. Due to a network issue only half of the ISO was downloaded. The installer started, but complained the same way you mentioned.

So before installing:

  • So check the file size of the ISO.
  • Search for your Windows version here and compare the SHA1 sum found in the details link with your ISO.
| improve this answer | |

For me the solution was to use the wired Internet connection while installing the virtual machine instead of wi-fi.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.