Nautilus used to be lightning fast.Now it's dead slow.

I have tried upgrading the video card but that does not seem to be the problem.

Also I found that there was a problem with the Dropbox uninstall, finally I replace it with pcmanfm which appears to be much faster but the down side is that I no longer have the gwibber social client and a lot of stuff don't work like they use to.

Also I completely removed nautilus and couldn't even login to ubuntu to install again nautilus.How can I remove or repair nautilus, and use pcmanfm instead?

I have a dell inspiron 1440 3gb ram / disk 300gb /

Additionally, why does nautilus run fast when I run it as root? There are no USB devices attached to my computer.

Thanks in advance

  • If you remove Nautilus you're taking much of the Gnome Desktop with it, just leave it there, and keep PcmanFM and replace it as the default file manager. Jul 19, 2012 at 17:26
  • If Nautilus is slow, there is probably something that is causing it to be slow besides the normal filesystem, such as some device or something like the gwibber social client. If you like Nautilus better than pcmanfm, why not try to find out what is making it slow? You could try running top (or better yet, htop) to see if something is using a lot of CPU. I don't use gwibber - can it be temporarily disabled? Any devices like USB, etc that can be disconnected? Any other changes that may have caused it to become slow? Jul 19, 2012 at 17:41
  • if i run nautilus a root runs lightning fast/ why is that?
    – david
    Jul 19, 2012 at 17:47
  • Something's wrong with your config. files then. Jul 19, 2012 at 17:49
  • what do you recommend? replace config files erase them and i will auto create them? not sure about this!
    – david
    Jul 19, 2012 at 17:57

4 Answers 4


I think you sould might install PCManFM (File Manager like Nautilus), it's the default file manager on Lubuntu, it's is "lightning fast" and it's interface looks like Nautilus.

You can install it from the Terminal with:

$ sudo apt-get install pcmanfm
  • 1
    pcmanfm is awesome Jan 26, 2014 at 14:55
  • It working like a black jaguar which running on the plain.
    – pylover
    Jan 31, 2014 at 1:22

You may try to launch nautilus from terminal, and if you would see the fallowing samba error: "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory Please ask your system administrator to enable user sharing." Then you could just remove the ../usershare and nautilus should speed up.

  • What do you mean when you say to "remove the ../usershare"? Mar 11, 2013 at 11:08
  • /var/lib/samba/usershares Mar 13, 2013 at 22:46
  • I do get exactly the message quoted above, about /var/lib/samba/usershares. But I don't have a /var/lib/samba/usershares directory. Only a /var/lib/samba/private. Jan 26, 2017 at 15:27

I had this problem too. For me I solved it by removing a symbolic link on the root directory which pointed to a network mount (smbfs) that wasn't reachable at the time. It also caused other gnome applications like gedit (gnome-text-editor) to become very slow.

I guess you would have the same problem if you have an unreachable network mount directly below the root. You should see the same lag if you simply do a 'ls /' in a terminal window. Apparently some apps That triggered me to find the solution.

Removing the symbolic link solved it for me.

  • How do you find out whether you have such a symbolic link which one should remove?
    – Rasmus
    Nov 6, 2012 at 19:15
  • No, the nautilus is really slow, it has more problems.
    – pylover
    Jan 31, 2014 at 1:28
  • @Rasmus, you should do sudo ls -la / | grep "\->". But this is not the issue! Apr 3, 2019 at 20:36

I had a similar problem - not sure about what "slow" you are talking here, but my slow was about nautilus slow start up and annoying rotating (busy) cursor when switching directories.

Solution: try running nautilus from terminal command line - just like

you@yourhost$ nautilus

if this brings the joy back in form of nautilus without lag then just edit the link/shortcut/launcher properties by changing field

Command: "nautilus %U" into just "nautilus" without fancy %U

worked for me. Hope it will help u2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.