I have a ruvo with a fresh installation of 12.04. When I try and shutdown the computer reboots. Until I upgraded (by doing a fresh install) I ran it with Ubuntu 10.04 and I didn't have this issue.

I have tried

sudo shutdown -h now 
sudo shutdown -P now
sudo init 0
sudo poweroff

All of these cause a reboot.

I have added acpi=norq to my grub file as suggested by someone in the first post below.

This is being used as a mythtv frontend and I would like the power button to shut it down. I have modified the button to perform a shutdown -h now, but this too causes a reboot.

I have studied the posts below and tried some of these ideas, but with no luck so far.

  • We need more information. First open your terminal. run this command for shutdown "sudo shutdown -h now". When ubuntu will show purple screen press up key(if not work then press couple of time) she will show the process(what is she doing). Detect where she stuck at.
    – shantanu
    Jul 19, 2012 at 12:39
  • It isn't getting stuck. It reboots rather than shutting down and power off. It all happens very quickly, and nothing looks out of place. I see a message in the terminal announcing a power down. Then as you say the purple screen comes up and when I press up arrow I only get to see the log for a couple of seconds, the last thing is deactivating swap followed by will now halt. But then the power stays on and it starts booting again.
    – Luca
    Jul 20, 2012 at 10:01
  • How does an OS tell a PC to reboot rather than shutdown? Could it be sending the wrong signal?
    – Luca
    Jul 20, 2012 at 10:03
  • @shantanu By filming shutdown :- In the terminal I get a "Broadcast message from <user>@<hostname> The system is going down for a halt NOW!" Then I see "* Checking battery state... [OK] / Checking for running unattended-upgrades: / acpid:exiting / speech-dispatcher disabled: edit /etc/default/speech-dispatcher / *Asking all remaining processes to terminate... [OK]/ *All processes ended within 2 seconds.... [OK] / vm-dispatcher.action: Caught signal 15, shutting down... / Deconfiguring network interfaces [OK] /Deactivating swap...[OK] / umount: /run/lock: not mounted/ Will now halt/[]Power down
    – Luca
    Jul 20, 2012 at 14:21
  • This is a known bug. Check the bug page for info. Edit: Try booting with acpi=off apm=off (i.e. both power managers off), and see what happens.
    – whiskers75
    Jul 28, 2012 at 16:56

1 Answer 1


I built a system and it would always restart after shutdown. Around the same time I did 2 systems for others with the the same Ubuntu versions and they always shut down just fine. After trying some things in the O/S every now and then, nothing worked. I finally went into the BIOS under Power Management and shut off everything except leaving base ACPI enabled. Otherwise cool'n'quiet wouldn't work. I did change an S1 setting to S3, disabled everything else(except the base ACPI settting) and changed the control from BIOS to O/S(I figured this way after linux shuts down it won't have any ability to start the system but BIOS still may be able to). After I did these things it finally would shut off -after dealing with this for over 2 and a half years! It's really quite ridiculous but in my case, the blame seems to lie with an MSI motherboard. The two other systems that shut down like they're supposed to are 2 different models of Biostar motherboards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .