3

When I insert by usb key nothing happens (i.e. the drive is not visible). I can mount the USB drive from gparted though (and then it's suddenly recognized).

It's not particular to any USB key. This only happens on my laptop (on the desktop the same key will be mounted upon plugging it in without any problems). Finally, the key is formated as fat32 and dosfstools and mtools are installed (through gparted claims otherwise).

what's the catch?

EDIT Also, gparted offers me the option to mount the key on "/" : shouldn't that be "/media" (or has this changed ?)

1

Using Alt+F2 open the run dialogue box.

Enter gconf-editor and Go To> apps> nautilus> preferences> LOOK AT media_automount and media_automount_open check the boxes and exit.

Ubuntu Docs

enter image description here

0

Maybe this: ALT + F2 and fill in: gconf-editor Then go to apps - nautilus - desktop - volumes visible (If this is set to true, icons linking to mounted volumes will be put on the desktop)

  • nop: it was already set to true. when i use gparted to show all flags for the usb key, none of them are checked. Is this normal ? – user2413 Dec 7 '10 at 20:34
  • Again, once mounted from within gparted all works like usual. It's just that i would prefer to be able to mount my usb keys simply by plugging them in, rather than thru gparted each time. – user2413 Dec 7 '10 at 20:37
0

Another option to try: When the usb is mounted, go to System > Preferences > Startup Applications > Options. Click on the button to remember applications. But before that make shure that all other applications (such as firefox etc) are closed. Then reboot.

  • that didn't help either. One thing that may be of interest: when i mount the keys in gparted a little red bang sign is displayed next to the partition's name. Double clicking it says: "Unable to read the contents of this file system! Because of this some operations may be unavailable". But then again, at this stage the key is mounted alright and i can access it thru nautilus/the link on the desktop -as usual. – user2413 Dec 7 '10 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.