I have reinstalled my system, a Samsung Series 9 laptop with a clickpad, under Ubuntu 12.04. I reinstalled it a few times and re-configured it with the same OS because I had issues with the filesystem getting corrupted (ext4 on this SSD with this kernel isn't so great apparently).

Anyway, I re-installed it for a Nth time and configured the ClickPad the same way as before:


Section "InputClass"
        Identifier      "np900x3b clickpad"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option          "ClickPad"      "1"
        Option          "ClickFinger1"  "1"
        Option          "ClickFinger2"  "3"
        Option          "ClickFinger3"  "2"
        Option          "FastTaps"      "1"
        Option          "RightButtonAreaLeft"   "2000"
        Option          "RightButtonAreaTop"    "1500"

I had the same configuration before (I actually copied it from a USB drive), and it worked fine. Yet I get this after restarting X:

$ synclient -l | grep -i "\(right\|click\|fast\)"
    RightEdge               = 2974
    ClickTime               = 100
    FastTaps                = 1
    ClickFinger1            = 1
    ClickFinger2            = 3
    ClickFinger3            = 2
    AreaRightEdge           = 0
    ClickPad                = 1
    RightButtonAreaLeft     = 0
    RightButtonAreaRight    = 0
    RightButtonAreaTop      = 0
    RightButtonAreaBottom   = 0
    MiddleButtonAreaRight   = 0

It appears that all options are being handled properly, except the RightButtonArea[...] ones. Looking at X logs gives me no clue about the problem, with no errors, only this:

[  1499.416] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[  1499.416] (**) Option "ClickPad" "1"
[  1499.416] (**) Option "FastTaps" "1"
[  1499.416] (**) Option "ClickFinger1" "1"
[  1499.416] (**) Option "ClickFinger2" "3"
[  1499.416] (**) Option "ClickFinger3" "2"
[  1499.416] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found

If I set them manually using synclient:

synclient RightButtonAreaLeft=2000

...then it works, but obviously I have to set manually them every time I start X.

Note that RightButtonAreaLeft depends on ClickPad=1 to work, although it is set correctly.

So it seems that the RightButtonArea[...] options are simply ignored by X. Like I said, I just reinstalled the system a few times before and it worked perfectly fine on every occasion.

Any help is greatly appreciated.


As a temporary workaround, I've found this.

I've created a script, /usr/share/X11/startup.sh:


synclient RightButtonAreaLeft=2000
synclient RightButtonAreaTop=1500

...and modified /etc/lightdm/lightdm.conf accordingly:

# ...

Seems to do the trick for now. I would still like to know if there's any way to fix this behavior in X.


In /usr/share/X11/xorg.conf.d/*.conf you need to use the option "SoftButtonAreas" followed by eight values (left, right, top and bottom for the right and middle button).

See http://manpages.ubuntu.com/manpages/trusty/man4/synaptics.4.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.