I tried to run

optirun glxgears

and I got this output:

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.
Please[ERROR]Aborting because fallback start is disabled.

What should I do?

  • Could you paste the full error using the code sample (<$> icon) tool? That way we can know the full problem without askubuntu breaking the formatting :) – MiJyn Jul 19 '12 at 2:35
  • @lkjoel <$ optirun glxgears> [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please [ERROR]Aborting because fallback start is disabled. (click edit to see the format i am new to ask) – Annani123 Jul 19 '12 at 14:34

  So to get Bumblebee to work

a) Run the following command to find out the BusID for your Nvidia graphics card:

 lspci | grep NVIDIA

The BusID is the number in the beginning of the line returned by the command above. Here's how the output for the command above looks like on my laptop:

 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev ff)

The BusID is the number in bold, "01:00.0" in my case.

b) Now we'll have to add the BusID to /etc/bumblebee/xorg.conf.nvidia and for this, we'll open the file as root with a text editor (I'll use Gedit in the command below):

 sudo gedit /etc/bumblebee/xorg.conf.nvidia

And in this file, in the "Device" section, add the following:


Replacing "YOUR_BUS_ID" with the BusID returned by the command used under step a). For me (remember, for you, the BusID may be different), this line looks like this:

  BusID "PCI:01:00:0"

Then, restart your system and Bumblebee should work so when you want to run an application or game on your Nvidia card, use:

 optirun APP_OR_GAME
 optirun glxspheres

Help > W E B U P D 8 Check Bumblebee Section

| improve this answer | |
  • i am having the same prob ...this fixed it – Qasim Apr 26 '13 at 0:09
  • This fixed it for me. In fact, the config file specifically states that it's needed for Ubuntu 13.04, which I'm using. May not be applicable to the original question, but might help others. – Nick Jun 6 '13 at 18:53
  • did not fix it for me :( .. using arch – philx_x Nov 19 '16 at 14:27
  • @philx_x are you getting the same error. After making a change try rebooting – Qasim Nov 19 '16 at 14:58

I ran into exactly the same issue just minutes ago on my Dell e6420.

Turns out there is a bug report in the Bumblebee git repo for this.

The solution given there, to delete the thinkpad conf file worked for me (strange since I have a Dell latitude and not thinkpad)

sudo rm /usr/share/X11/xorg.conf.d/10-nvidia-current-thinkpad-t420s.conf
| improve this answer | |
  • rm: cannot remove `/usr/share/X11/xorg.conf.d/10-nvidia-current-thinkpad-t420s.conf': No such file or directory – Annani123 Jul 19 '12 at 14:35
  • could you post the output of doing an ls in that directory, ie. sudo ls /usr/share/X11/xorg.conf.d/ – Maks Jul 19 '12 at 22:16
  • uptikool@fenrir:~$ cd /usr/share/X11/xorg.conf.d/ uptikool@fenrir:/usr/share/X11/xorg.conf.d$ ls 10-evdev.conf 50-synaptics.conf 51-synaptics-quirks.conf 11-evdev-quirks.conf 50-vmmouse.conf 11-evdev-trackpoint.conf 50-wacom.conf uptikool@fenrir:/usr/share/X11/xorg.conf.d$ – Annani123 Jul 20 '12 at 1:46
  • ok, thats the same as I have. Could you provide some more information in your question about which version of ubuntu you are using?, what you have already done so far (eg. which PPA's you have added), etc. – Maks Jul 20 '12 at 4:59
  • i am using 12.04 and i followed these instructions wiki.ubuntu.com/Bumblebee i recently switched over from fedora – Annani123 Jul 20 '12 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.