2

I'm running Ubuntu 12.04, 64 bit

I noticed that "compiz" was eating 40% of one of my CPUs and wanted to find its configuration. After not being able to find anything in the "Settings" with words compiz or similar (I'm used to 11.04 where I had 3 settings for fanciness of animations etc) I started googling. Most suggestions say to do this:

gconftool-2 --recursive-unset /apps/compiz

or

gconftool-2 --recursive-unset /apps/compiz-1

I did the -1 action and my Unity closed. Restarting the computer does not bring any window manager back up. I get desktop with 2 icons, and no window manager.

How can I solve this?

P.S Shortcuts don't work. Alt-F2 does nothing, single tap on Alt, Ctrl, Super does nothing. To open a terminal I have to open a Desktop folder icon, then search for gnome-terminal in /usr/bin and open it that way. All windows that open up cannot be resized etc.

2

Open up a terminal by browsing to /usr/share/applicationsin your file manager and double-clicking gnome-terminal.desktop. Now, run unity --reset.

  • Thank you! After running that command my terminal froze, but resetting the desktop via Alt+Prnt+k finalized this. – Mikhail Jul 19 '12 at 14:08
  • 2
    The --reset switch is now depreciated, at least in 14.04. Is there an alternative please? – Robula Apr 10 '14 at 8:48
2

I had the similar problem in 14.10 . I solved it by deleting my ~/.config/dconf/user and ~/.cache/compizconfig-1. It worked out for me, in case if it doesn't work out for you try installing a different window manager(in my case I had cinnamon and was able to use it smoothly even when I had problems in default window manager).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.