29

I have installed Ubuntu 12.04-64 bit on my Lenovo IdeaPad laptop, and the wired Ethernet (LAN) connection doesn't work.

Running the lspci -vv | grep Atheros command from the terminal shows me I have the AR8161 Gigabit Ethernet controller:

02:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 08)

This looks like a new product whose drivers are not built into Ubuntu.

How do I install drivers to get the AR8161 working?

  • sudo modeprobe ath9k – BigSack Aug 14 '12 at 13:47
  • 1
    Please remember to accept/upvote the best answer(s) to your question when possible (tick/check mark on the left). This way, the question is marked as "answered" and future readers can refer to it knowing the solution works. Thank you...:) – ish Aug 26 '12 at 17:11
  • This answer (askubuntu.com/a/736589/194156) helped me solve this problem. TL;DR, in Network Manager, set the MTU to 8192. – Xin Aug 29 '16 at 7:42
36

The AR8161 is a very new combined Ethernet/Bluetooth controller and its driver alx is in the testing/QA process, so it's not in the kernel yet.

To build and install the driver:

We will download a recent compat-wireless-pc driver package, install build dependencies, select the AR8161 module alx, build and install it.

Type/paste the following, line-by-line, in a terminal:

sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
wget -O- http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2012-07-03-pc.tar.bz2 | tar -xj
cd compat-wireless-2012-07-03-pc
./scripts/driver-select alx
make
sudo make install

You can then reboot, or manually load the driver with:

sudo modprobe alx
| improve this answer | |
  • Thanks i made this a gist! gist.github.com/3406323 – chrisjlee Sep 5 '12 at 15:01
  • 7
    How the heck "sudo apt-get install" if the network card is not working?? – Ivan Nov 14 '12 at 22:22
  • Note that the "compat-wireless" drivers referred to here are the same as the officially supported and maintained "-backports-modules-cw" below - you should really prefer that solution, now that it is available. – Greg Dec 28 '12 at 11:53
  • I use the by now delivered alx driver, wireless works, but wired ethernet does not. Haven't had such issues in a long time. I think it is time that we start to rumble on manufacturer's social websites if they still release new hardware without proper linux drivers - this really should be ended now. Place your comments on their social media sites mentioned in the footer of atheros.com .. I certainly did.. – Bachi Apr 7 '13 at 10:49
  • 2
    @Ivan, I'm sure you've moved on by now, but, help.ubuntu.com/community/AptCdrom – Tim Harper Jun 12 '13 at 20:37
24

Ubuntu now provides a package for this driver.

To install the driver:

sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
sudo modprobe alx
| improve this answer | |
  • 4
    or newer 3.5, 3.6, available as packages too, e.g. linux-backports-modules-cw-3.6-precise-generic – gertvdijk Jan 1 '13 at 23:33
  • 1
    Make sure you bring up the interface afterwards, ie: ifconfig eth0 up && sudo dhclient eth0 – Scott Ritchie Feb 8 '13 at 22:34
  • 3
    @gertvdijk Nope, newer packages don't contain the alx module. Only 3.4 works. Don't know the reason. The card is not claimed by any driver with 3.6 version at least. packages.ubuntu.com/… – Jorge Suárez de Lis Feb 15 '13 at 11:24
  • @JorgeSuárezdeLis Actually, I can confirm 3.6 has worked. I just installed 3.6 before I read your comment but it seems to have worked anyway. – Cyntech Jun 15 '13 at 13:02
  • linux-backports-modules-cw-3.8-3.2.0-48-generic did NOT have alx installed. Also, if you have no Internet connection on your target machine, you can download the driver from pkgs.org/ubuntu-12.04/ubuntu-updates-main-amd64/… (be sure to modify the last set of numbers to match your current kernel (see uname -a) – User1 Jul 10 '13 at 4:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.