So here is my story...

I was doing upgrades to ubuntu the other day, and the power went out right in the middle of the upgrade, so now when I try to do upgrades it keeps asking me if I want to do a partial upgrade. I have heard this is bad and should be avoided, I also know there is a way to fix this via the command line, but I can't remember how, nor can I find anything on the internet.

Any help would be appreciated. Thanks alt text

5 Answers 5


It looks like sudo dpkg --configure -a is the magical command.

Here is the dpkg man page’s explanation of the --configure -a options:

--configure package...|-a|--pending

Configure a package which has been unpacked but not yet configured. If -a or --pending is given […], all unpacked but unconfigured packages are configured.


Configuring consists of the following steps:

  1. Unpack the conffiles, and at the same time back up the old conffiles, so that they can be restored if something goes wrong.

  2. Run postinst script, if provided by the package.

  • 1
    usually that fixes it all, if it doesn't try firing up synaptic, or do sudo apt-get install aptitude, and then sudo aptitude (should have a gtk gui with Maverick). aptitude is usually better at finding/fixing the problems.
    – RolandiXor
    Dec 7, 2010 at 3:33
  • 6
    Doesn't have noticeable effects on my box. Still offers a partial upgrade.
    – tutuca
    Apr 27, 2013 at 1:05

I'd suggest trying this:

sudo apt-get install aptitude
sudo aptitude update
sudo aptitude dist-upgrade

Solved the issue for me, probably will work for you as well.


I had the same problem. What I did was, obtain the list of packages from sudo apt-get upgrade. In my case:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  linux-generic linux-headers-generic linux-image-generic
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

Then I installed the "not upgraded" packages with sudo apt-get install linux-generic linux-headers-generic linux-image-generic and problem solved.

  • 1
    You could also have done sudo apt-get dist-upgrade.
    – Seth
    Mar 9, 2013 at 15:15

partial upgrade means that something went wrong with an installation or update. I started receiving this partial upgrade prompt after a botched Mplayer media player installation. I removed the software and via the purge command got rid of everything associated with Mplayer media player. This also interfered with some plugins i had installed for gstreamer and VLC. I reinstalled what i had lost and the partial upgrade prompts quit showing up. I suggest you find out what happened especially with a recent installation of a PPA


you can try sudo apt-get update through this files will be updated. and then you can upgrade through terminal by typing sudo do-release-upgrade when it will ask Installing the upgrade can take several hours. Once the download has finished, the process cannot be canceled. then press 'Y' thats all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .