1

when trying to customize my ubuntu desktop live iso i'm coming across an rsync error in the first stages of the tutorial.

when I execute:
sudo rsync --exclude=/casper/filesystem.squashfs -a mnt/ extract-cd
The copy starts with no output. I left this running for around 40 minutes and have assumed that something went wrong in the copy.
sudo rsync -ax mnt/ extract-cd I tried this command too and I got the same error after pressing ctrl+c.

This is the error I am getting:

    rsync error: received SIGINT, SIGTERM, or SIGHUP (code 20) at rsync.c(549) [sender=3.0.9]

any suggestions/tips would be welcome

Edit

This is the link to the output from the command you suggested I run:rsync output

I looked at your recommendation of using ubuntu-builder. I am using ssh to access the computer with no possibility of using an UI.

I tried the ubuntu customization kit this morning running the by running the uck-remaster-unpack-iso. My understandinf of this command is that it runs a script similar to what I was typing in by hand. This command also stops producing output and I exited it after 10 minutes(No error output was given).

1

The error is simply caused by your pressing Ctrl+C to interrupt rsync.

The command should work; since it's not, please try running this and let us know what the output is:

sudo rsync --exclude=/casper/filesystem.squashfs -a -nPh mnt/ extract-cd

The only difference is the additional -nPh option: - -n indicates a dry run, or a simulation; rsync will simulate what happens, including any errors, without actually copying any data. - -Ph shows the progress file-by-file in "human" readable (i.e. kilobytes, megabytes, etc.) form.


Please note: The Ubuntu customization wiki is terribly outdated. I highly recommend usin a more modern, user-friendly customization solution that takes care of extracting, mounting, chrooting, etc. for you.

Ubuntu Builder is my tool of choice. Please see this answer of mine for a more-hands-on tutorial of using Ubuntu Builder to customize 12.04.

  • the ubuntu builder seems like a useful application, I will test it out when I can use my ui again – hamhut1066 Jul 19 '12 at 10:25
0

I believe I found the problem, There is another problem on my computer causing very low write speeds to ntfs. Therefore When I tried to run rsync the copy simply would not complete in a feasible amount of time.

0

After installed below packages, the problem solved.

sudo apt-get install libgcrypt11

sudo apt-get install libgcrypt11:i386

  • 1
    Why libgcrypt11 and libgcrypt11:i386? – Stephen Rauch Jun 23 '18 at 2:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.