Oki so running any kind of variation of debootsrap i get the following error

I: Extracting zlib1g...

W: Failure trying to run: chroot /lxc/iso/dodo mount -t proc proc /proc

debootstrap.log :

mount: permission denied

if i manualy chroot into the directory then i get promted with:

id: cannot find name for group ID 0

I have no name!@...#

i tryed addgroup but it's not installed , apt-get/aptitude : command not found , so i can't do anything with it .

I've tryed ubuntu-vm-builder but since it's calling debootstrap i get the same error .

Played with it for a few days and then i stoped and gaved virt-install a try , everithing works till i get to the console to finish the install witch shows only :

Escape character is ^]

and nothing more , no matter what i type .

So basicly what i'm trying to do is build a usable chroot system so i can use it with lxc or libvirt .

What are my options to get containers/virtualisation up and running ? I've read somewhere that i can use openvz templates with lxc or libvirt ? but how ?

Let me know if you need aditional info ( p.s. doing all this on a dedicated server so i can't access it by hand , only ssh , plus on my local pc running ubuntu desktop maverick everithing works ) .


Getting closer , i managed to understand how to use an openvz template with lxc , now the problem comes with the network bridge

lxc-start: invalid interface name: br0 # Use same bridge device used in your controlling host setup
lxc-start: failed to process 'lxc.network.link = br0 # Use same bridge device used in your controlling host setup
lxc-start: failed to read configuration file

i followed the exact steps to create a bridge and lxc conf looks like:

    lxc.network.type = veth
lxc.network.flags = up
lxc.network.link = br0 # Use same bridge device used in your controlling host setup
lxc.network.hwaddr =  {a1:b2:c3:d4:e5:f6} # As appropiate (line only needed if you wish to dhcp later)
lxc.network.ipv4 = {} # (Use if you wish to dhcp later)
lxc.network.name = eth0 # could likely be whatever you want

Since it's not working i know smth is wrong so could somebody guyde me ?

EDIT , looks like the base install was using an custom kernel ( bzImage- ) for witch you i didn't found the headers , i did a update-grub after i installed a new kernel , edited menu.lst and no it's using 2.6.35-23-server and now debootstrap is working just fine same as ubuntu-vm-builder .

  • you have about five different questions there. Please post one question per different approach that you're trying. – poolie Dec 7 '10 at 0:41
  • indeed i'm asking too many questions in one post , however my goal is to get a virtual machine working inside my dedicated server , i realy don't care witch technology will be used , since none works i suspect the problem is in the same place for both aproaches . – poelinca Dec 7 '10 at 7:00

This command worked for me:

sudo lxc-create -n my-vm -t ubuntu

but I didn't generally find that lxc was very mature. Using kvm:

vm-builder kvm ubuntu

Perhaps the simplest solution is: download an Ubuntu ISO, run virt-manager, create a VM through the GUI, attach the ISO to the CD drive, then boot it and install in the usual way.

  • i'm doing this on a dedicated server i can't access any GUI tools just plain old console – poelinca Dec 7 '10 at 6:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.