I successfully installed Ubuntu Server 12.04 32-bit on a HP Proliant Microserver, everything works perfectly but when I try to turn off the machine with the command halt or poweroff hangs after disabling everything and stays on the screen System halted and can no longer interact or reach it from network, the only thing I can do is shut it down forcibly with the power button.

Initially even reboot did not work but after editing the /etc/default/halt file, it worked:


I followed some forum where advised to modify /etc/default/grub, by changing the line: GRUB_CMDLINE_LINUX_DEFAULT="" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

But it did not work for me.

I tried to do the opposite and disable ACPI in the BIOS and grub setting: GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash acpi=off noacpi"

The same. I repeat there is no graphical environment.

Have someone found other solutions?

  • I think the problem is hardware-independent because it is being reported for various PCs, although it could perhaps be linked to the bios... Does anyone have an idea or a suggestion? – Nitrox Jul 19 '12 at 10:06

Try with this command in the console, run as root:

shutdown -h now

It works for me.

  • 2
    The man page to shutdown states for the -h option: "Requests that the system be either halted or powered off after it has been brought down, with the choice as to which left up to the system." The best choice is to use "shutdown -P now" – Colin Ian King Aug 11 '12 at 16:09

This problem seems to be so common with the latest kernal versions.

I too have the same problem and tried lot of solutions, but none work for me. Finally, I downgraded the kernal by installing the lower kernal version 3.2.0-23.

This fix my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.