As in the subject, if my external keyboard is attached to my Dell Vostro 3750 laptop (via usb 3) - Ubuntu does not want to boot - I see only black screen. Could you please help me?

  • Have you tried USB 2? – Mitch Jul 16 '12 at 20:10
  • Also I upvoted the question seeing as several Dell Vostro's have this issue, it'd be nice to get a solve on it. – Oyibo Jul 18 '12 at 12:37

If you've installed Ubuntu from a USB, you might have asked your laptop to boot from one of your USB ports when you installed it. And because of that each time you try booting and there is a USB device plugged in such as your keyboard (some peripherals have software incorporated), it tries booting from there, it might only happen on that USB port because you might have had the choice of a specific port (if this isn't the case ignore this post).

But if it is, check the boot order of your laptop in the Bios Boot Menu, and make sure your laptop is set to Boot from your hard-drive first then CD then USB. That way it won't try to boot from something else and it should work properly with your keyboard plugged in.

  • My Dell Vostro 3700 does not boot if USB 2.0 mouse is attached. I've installed Ubuntu (12.04; the same thing with 11.xx) from CD disk. – brownian Jul 18 '12 at 8:26
  • Have you tried doing everything I suggested in my post? If you did what happened? I'd like to help you but I need as much information as possible to be able solve your problem. – Oyibo Jul 18 '12 at 8:48
  • 1
    Oyibo, thanks for response. I installed Ubuntu 12.04 from DVD. My boot order is set to: - first from disk, second from CD/DVD, third from internet, and last from usb 3, so boot order is correct. It is problem with USB 3, my mouse is always attached to USB 2 and Ubuntu starts properly (without external keyboard connected to USB 3). I tried to change: mouse to USB3, external keyboard to USB2 but it did not help. The same issue I had with Fedora 16 so this is only laptop (bios, hardware) issue. – Slawek Jul 18 '12 at 10:08
  • As you've said you have the same with Fedora 16 it's unfortunately likely to be a hardware issue (you can check around with other people but the Bios is rarely faulty I've found from experience), so you have several ways of sorting this out, either you find the solution on a forum about hardware, but it seems to be a problem only affecting Dell Vostro's so not sure how easy that will be (also most people on askubuntu and online can help you with software issues and not as much with hardware unfortunately) – Oyibo Jul 18 '12 at 12:27
  • otherwise if you're planning on regularly having a keyboard+mouse plugged in I'd use a USB splitter like this and plug both into your USB 2 port. Hope I was of some help, sorry for not being able to help more, I'm not very aware of how to handle hardware issues. Hope you get the issue fixed. (Sorry had to post in 2 comments because my original was too long) Hope you get the issue sorted anyways, good luck! – Oyibo Jul 18 '12 at 12:27

I also have Dell Vostro 3750 i7 quad core.

If there is anything plugged in in USB3 port(s) - Ubuntu would not boot properly and would just show blank screen or a cursor blinking in the top left corner of the screen.

The solution is to unplug whatever is plugged in USB3 port(s) - say mouse or USB stick or 4 port hub or whatever, and Ubuntu would boot up normally. It boots normally if peripherals are plugged in USB2 port.

Worth mentioning is that these problems do not exist when booting Windows 7 (64 bit, preinstalled on this Dell Vostro 3750): this USB3 problem happens only with Ubuntu.

I faced this problem when installing Ubuntu too. I had the USB plugged into USB3, but when I plugged it into a USB2 port, Ubuntu 12.04 LTS installed in a second.

It seems USB3 and Ubuntu boot or install process have some problems/bugs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.