What Ubuntu features do and which do not work on your Shuttle XS35 barebone mini-pc? In the spirit of this question, add your experience, good or bad, with this fanless, i.e. passively cooled, small-form-factor computer, based on Intel's Atom, to this community wiki.

  • This would benefit from being marked community wiki.
    – loevborg
    Dec 6, 2010 at 14:54
  • Converted to Wiki Dec 6, 2010 at 14:55

6 Answers 6


I bought a Shuttle XS35 specifically to use as a media centre for my lounge room.

Installation of Ubuntu 10.10 was a breeze up until it was time to reboot. The eject button on the DVD Drive did not work so I rebooted anyway without removing install disc. After reboot, the eject would still not work, it just made a soft screeching type sound. Trying to run the "eject" command from the console gave the same response. I managed to get it open using a pin in the "emergency eject" pinhole of the drive. Now eject seems to work normally - strange.

Next thing I found is that Ubuntu would not auto-detect my Wireless LAN. This seems to be a problem in BIOS 1.08 as shipped with the box (as mentioned above). BIOS 1.08 offers the following options for "Wireless Power Control": "Disabled", or "Switch by AP".

Now according to ubuntuforums posts, this can be fixed by flashing to BIOS 1.09 and selecting the new option of "Always On". I have yet to try this as BIOS 1.09 has been removed from the Shuttle website.

I tried installing and running XBMC before I had installed the proprietary NVidia drivers to see how it would fare on ION without GPU acceleration - it was completely unusable. Fortunately installing the NVidia proprietary drivers was straightforward and now XBMC works with no performance issues.

With default install my MCE compatible remote control had some buttons working and others not. After installing lirc and configuring it for my device (a single drop-down during install), it is working a charm! I am puzzled that it partly worked at all without lirc ... ?

In summary, so far everything has been awesome except the wireless problem, which is a serious pain.

  • Thanks for the comment. I, too, would love to see the wireless problem fixed.
    – loevborg
    Feb 16, 2011 at 9:14

Here's a copy of the 1.09 bios you need to get the wifi to work. It's been working for me for the past few months, although it drops the signal way too frequently. Reconnecting to the router via the menu bar icon works.


Ubuntu Server 16.04 LTS (x86_64) on XS35GT, wired Ethernet. (no WLAN needed)

Dug out my old 2011 Shuttle XS35GT w/win7 in order to re-commission it as a openHAB server.

Since it going to be tucked away on my LAN, I opted for Ubuntu Server 16.04 LTS

Since I was sent on a wild goose chase with issues concerning previous Ubuntu versions, I just want to share my experience so that others might save some time.

The installation process fails to find any network devices, but fear not, just continue until finished.

My mistake was that, based on previous issues others had in the past, I thought I needed to updated jme driver and the latest BIOS for the Shuttle. This is not the case. Shuttle BIOS 1.08, and the jme driver that comes with the install (v1.0.8) turned out to work OK.

It all boils to setting up the interface.

Start with:

$ networkctl
WARNING: systemd-networkd is not running, output will be incomplete.

IDX LINK             TYPE               OPERATIONAL SETUP
  1 lo               loopback           n/a         unmanaged
  2 enp2s0f5         ether              n/a         unmanaged
  3 wlp3s0           wlan               n/a         unmanaged

3 links listed.

Note that the expected eth0 is now history and is replaced by enp2s0f5 in my case.

Also note that the WLAN interface is found, but I did not pursue it as I prefer my server wired.

Next set up the interface with a static IP, good for servers:

$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto enp2s0f5
iface enp2s0f5 inet static

Reboot, and you should be good to go.

$ ping askubuntu.com
PING askubuntu.com ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=57 time=8.00 ms
64 bytes from icmp_seq=2 ttl=57 time=7.96 ms
--- askubuntu.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 7.961/7.983/8.006/0.092 ms

On 10.10, the NVIDA-based ION GPU built into my XS35 works well after installing the proprietary NVIDIA driver using System / Administration / Additional Drivers. The nouveau driver worked well enough to cover the installation, but I suspect that it was the cause of a crash and that switching drivers improved stability.


Sadly the wireless does not work out of the box. On the server editions the ethernet is not detected either. I have seen posts on getting the wireless working with a flash of the bois but I still haven't managed to get this working even with the new bois.

  • Thanks. I haven't gotten it to work either. Let us know if you learn a way to enable the wireless chipset.
    – loevborg
    Dec 30, 2010 at 11:15

I own a Shuttle XS36V that I installed 11.10 on. In the bare-bones machine I put 2G of RAM and a cheap Seagate Momentus 250G HD. I prefer using the last x.10 version, even though 12.4 exists.

I used pendrivelinux Universal USB Installer to mount the iso to a thumb drive, stuck it in, booted to the BIOS screen using F2, set the thumb drive (detected) to boot order 1, rebooted, chose to run Ubuntu off the USB, then finally installed from inside it the running OS.

I then installed LAMP, PHPMyAdmin, and VSFTP (good instructions here). It works fine as a remote development server. I have it in my cubicle and me and the other web developer like it. I have a keyboard and monitor, and it seems as fast as any other machine I have used when doing typical desktop stuff.

Both RAM and CPU seem to use about 1/4 capacity and remote PHP development does almost nothing to spike these resources. Plus, I have to say, this mini computers is cool. No fan, so it is dead silent, and barely warm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .