I'm following the instructions to create a bootable USB stick on OS X and everything is fine until step number 8: I have executed sudo, entered my password and now nothing is happening.

I tried to go to step number 9 and ejected the USB stick and nothing happened. So I took it out manually and then the terminal reacted saying that it could not find the device. I tried to see if my USB stick worked on my ASUS EEE PC (where I want to install Ubuntu) and of course it didn't.

So I started the whole procedure again and don't know what I should do after entering my password - I am not getting any error message.

  • Try SuperUser as it deals with Macs and general writes to USB sticks.
    – nanofarad
    Jul 16, 2012 at 15:08

2 Answers 2


It always helps if you specify the site, which describes the steps you are following ;) In case you are following these instructions - the command is not just sudo, but

  sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m

where you need to replace the path accordingly. You can try this one, which seems much better formatted:

How to install Ubuntu on MacBook using USB Stick


I have tried this on a mac, and it takes a very long time - I think around 3-5 minutes.

Does it just start a new prompt like:

Maco@macosx ~$: sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
Maco@macosx ~$:█

If so, then something's definetley wrong. Or does it start a new line with a flashing cursor, like this:

Maco@macosx ~$: sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m

If so, it means it is copying the image and you probrably should leave it alone for some time (Especially (if your USB has a light indicator) if the light indicator on your flash drive is flashing - this means it is being accessed.), as I said, maybe 3-5 minutes, maybe longer.

And make sure that you are executing the command as a whole, not just sudo (As Stefan Buynov answered), so the location is probrably something like:

sudo dd if=~/Downloads/Ubuntu-12-04-i386.iso of=/dev/rdiskN bs=1m
  • You might want to click the '✔' tick symbol next to my answer - thanks! Jul 17, 2012 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.