12

This question already has an answer here:

I see this question is "answered" by stating that there is no way to do this in GNOME: How to move windows around and between monitors, using keyboard short cuts? I have doubts that it should be impossible and I really want to do it.

Is there really no way to do this is Gnome? This is my output from xrandr that I don't know how to use:

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 3840 x 1200, current 3840 x 1200, maximum 3840 x 1200
default connected 3840x1200+0+0 0mm x 0mm
   3840x1200      50.0* 

marked as duplicate by Warren Hill, Eric Carvalho, user68186, Alaa Ali, Radu Rădeanu Sep 26 '13 at 19:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Do you mean between monitors. OR do you mean between X11 screens? Between monitors is possible using XRandR or xinarama. XRandR was working out of box for me. – ctrl-alt-delor Jul 16 '12 at 12:48
  • I have kde and super + arrows moves to next edge as described in other question. – ctrl-alt-delor Jul 16 '12 at 12:56
  • 1
    Just to confirm - do you mean with Gnome desktop or Unity? – Julian Knight Jul 16 '12 at 15:24
  • 1
    not a duplicate of 28086, as this other is about unity, and other reasons (see other question) – ctrl-alt-delor Jul 16 '12 at 21:30
  • I mean default ubuntu gnome with two physical displays. When I open a PDF document for instance it is sent to the television for no reason even though the TV is turned off. – Niklas Rosencrantz Jul 17 '12 at 3:34
11

The following works for me (Ubuntu 12.10, Gnome Shell):

Ctrl + Alt + NUMPAD 6 moves the active window to the screen on the right

Ctrl + Alt + NUMPAD 4 moves the active window to the screen on the left

Note that, for some applications like Firefox and Thunderbird, this does not work for maximized windows for me -- the window seems to be moving, but only until I release the keys. This could be a bug in the corresponding applications or Gnome Shell. As a workaround, I unmaximize first using Ctrl + Alt + NUMPAD 5, and maximize back later with the same combination.

This is inspired by answers from How to move windows around and between monitors, using keyboard short cuts?.

EDIT: For some obscure reason these shortcuts stopped working for me. Super + NUMPAD 7 and Super + NUMPAD 9 achieve a similar effect.

  • That's good but did not work right away. I'm patching with the latest ubuntu updates to see what changes I can make to enable the functionality. – Niklas Rosencrantz Nov 28 '12 at 9:40
  • 1
    @NickRosencrantz: This is strange. I have scanned the list of my installed extensions, but didn't find anything suspicious. How would I find out who is responsible for handling the above key combinations in my system? Which Ubuntu version are you running? – krlmlr Nov 28 '12 at 10:25
  • 2
    None of the shortcuts are working :( – Yatharth Agarwal Mar 5 '13 at 12:52
  • 3
    On Fedora 24, I achieve this through Super + Shift + (arrow) – Waldir Leoncio Oct 12 '16 at 18:27
  • 1
    @WaldirLeoncio 's answer also matches the most up voted answer on the duplicate question – icc97 Jul 19 '18 at 8:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.